summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-09-20 15:50:11 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-09-20 15:50:11 +0000
commitab34c67af70e33e140ce1a342e645d039400c306 (patch)
treea75c0a90494878a8ccd053ebdd73634759fbc8f4 /dev-lang/pike/pike-7.4.28.ebuild
parentfix changelog (diff)
downloadhistorical-ab34c67af70e33e140ce1a342e645d039400c306.tar.gz
historical-ab34c67af70e33e140ce1a342e645d039400c306.tar.bz2
historical-ab34c67af70e33e140ce1a342e645d039400c306.zip
minor fixes
Diffstat (limited to 'dev-lang/pike/pike-7.4.28.ebuild')
-rw-r--r--dev-lang/pike/pike-7.4.28.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/pike/pike-7.4.28.ebuild b/dev-lang/pike/pike-7.4.28.ebuild
index c950ca17f50a..99034539d6fa 100644
--- a/dev-lang/pike/pike-7.4.28.ebuild
+++ b/dev-lang/pike/pike-7.4.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc., Emil Sköldberg (see ChangeLog)
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28.ebuild,v 1.1 2003/09/20 11:17:11 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28.ebuild,v 1.2 2003/09/20 15:50:06 scandium Exp $
inherit flag-o-matic
@@ -35,13 +35,13 @@ src_compile() {
# disable ffmpeg support because it does not compile
emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-ffmpeg" || die
- cd ${S}/refdoc
- PATH="${S}/bin:${PATH}" make || die
+ # only build documentation if 'doc' is in USE
+ if use doc; then
+ PATH="${S}/bin:${PATH}" make doc || die
+ fi
}
src_install() {
- # the installer should be stopped from removing files
- sed -i s/rm\(mod\+\"\.o\"\)\;/\{\}/ ${S}/bin/install.pike || die "Failed to modify install.pike"
make INSTALLARGS="--traditional" buildroot="${D}" install || die
if use doc; then