summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2004-07-12 16:29:57 +0000
committerRainer Groesslinger <scandium@gentoo.org>2004-07-12 16:29:57 +0000
commit0654f4ba0892222beda9bd32514445ce766e3312 (patch)
tree087cb223f322a19aaf7e459da406ad20d8521415 /dev-lang/pike
parentremove the unneeded lib/*.a cruft from a stage1 build (diff)
downloadhistorical-0654f4ba0892222beda9bd32514445ce766e3312.tar.gz
historical-0654f4ba0892222beda9bd32514445ce766e3312.tar.bz2
historical-0654f4ba0892222beda9bd32514445ce766e3312.zip
optionally enable nettle support
Diffstat (limited to 'dev-lang/pike')
-rw-r--r--dev-lang/pike/Manifest2
-rw-r--r--dev-lang/pike/pike-7.6.6.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-lang/pike/Manifest b/dev-lang/pike/Manifest
index 84b5f39e9736..cfced657dfc5 100644
--- a/dev-lang/pike/Manifest
+++ b/dev-lang/pike/Manifest
@@ -1,4 +1,4 @@
-MD5 764f8923397422252117baf101102582 pike-7.6.6.ebuild 3005
+MD5 fe1174afe601d6fd8760bfff715ac865 pike-7.6.6.ebuild 2997
MD5 de494ece933e48cc759bcb4728e41d90 pike-7.4.44.ebuild 3105
MD5 207a616cef884909a9b199595a737f32 pike-7.4.28-r2.ebuild 3353
MD5 1c9a2bbcd3ad4dca16ea65f2d28e0ce4 ChangeLog 1729
diff --git a/dev-lang/pike/pike-7.6.6.ebuild b/dev-lang/pike/pike-7.6.6.ebuild
index 6216199f3659..062236980632 100644
--- a/dev-lang/pike/pike-7.6.6.ebuild
+++ b/dev-lang/pike/pike-7.6.6.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.6.ebuild,v 1.3 2004/06/26 14:52:49 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.6.ebuild,v 1.4 2004/07/12 16:29:57 scandium Exp $
# Contributions by Emil Skoldberg, Fredrik Mellstrom (see ChangeLog)
inherit fixheadtails
-IUSE="debug doc fftw gdbm gif gtk java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
+IUSE="crypt debug doc fftw gdbm gif gtk java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
S="${WORKDIR}/Pike-v${PV}"
HOMEPAGE="http://pike.ida.liu.se/"
@@ -32,6 +32,7 @@ DEPEND="zlib? ( sys-libs/zlib )
sdl? ( media-libs/libsdl )
gtk? ( =x11-libs/gtk+-1.2* )
fftw? ( dev-libs/fftw )
+ crypt? ( dev-libs/nettle )
dev-libs/gmp"
src_unpack() {
@@ -65,9 +66,9 @@ src_compile() {
use opengl || myconf="${myconf} --without-GL --without-GLUT"
use gtk || myconf="${myconf} --without-GTK"
use fftw || myconf="${myconf} --without-fftw"
+ use crypt || myconf="${myconf} --without-nettle"
- # Using --without-nettle until the Nettle library is available in portage
- emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-nettle" || die
+ emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf" || die
if use doc; then
PATH="${S}/bin:${PATH}" make doc || die