summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:44:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 04:44:55 +0000
commitd36dc6ba5357b429cd7bf8ad76a9bbbec213360d (patch)
tree3353867e0a0b478c2aefb7851da3047045eeb2b3 /dev-lang/python
parentbeautified (diff)
downloadhistorical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.tar.gz
historical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.tar.bz2
historical-d36dc6ba5357b429cd7bf8ad76a9bbbec213360d.zip
modernised
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.1.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.1.3.ebuild4
-rw-r--r--dev-lang/python/python-2.2-r7.ebuild10
-rw-r--r--dev-lang/python/python-2.2.1-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.2.1-r2.ebuild4
-rw-r--r--dev-lang/python/python-2.2.1.ebuild14
6 files changed, 20 insertions, 20 deletions
diff --git a/dev-lang/python/python-2.1.3-r1.ebuild b/dev-lang/python/python-2.1.3-r1.ebuild
index 98faa86cf862..23e1ad6a0374 100644
--- a/dev-lang/python/python-2.1.3-r1.ebuild
+++ b/dev-lang/python/python-2.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.3 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -33,7 +33,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
diff --git a/dev-lang/python/python-2.1.3.ebuild b/dev-lang/python/python-2.1.3.ebuild
index da974960b000..3efad9e893c1 100644
--- a/dev-lang/python/python-2.1.3.ebuild
+++ b/dev-lang/python/python-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3.ebuild,v 1.3 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -33,7 +33,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
diff --git a/dev-lang/python/python-2.2-r7.ebuild b/dev-lang/python/python-2.2-r7.ebuild
index e4cbba0c10a5..de0f8e36a1e8 100644
--- a/dev-lang/python/python-2.2-r7.ebuild
+++ b/dev-lang/python/python-2.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r7.ebuild,v 1.4 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r7.ebuild,v 1.5 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,10 +36,10 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
# adjust Setup to include the various modules we need
cd ${S}
- # turn **on** shared
+ # turn **on** shared
scmd="s:#\(\*shared\*\):\1:;"
# adjust for USE readline
if use readline; then
@@ -79,11 +79,11 @@ src_compile() {
# no USE vars to switch off these adjustments:
scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
+ scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
sed "$scmd" Modules/Setup.dist > Modules/Setup
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1-r1.ebuild b/dev-lang/python/python-2.2.1-r1.ebuild
index e38d947e66e8..d4be93ba8289 100644
--- a/dev-lang/python/python-2.2.1-r1.ebuild
+++ b/dev-lang/python/python-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r1.ebuild,v 1.3 2002/07/21 00:59:19 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r1.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,7 +36,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1-r2.ebuild b/dev-lang/python/python-2.2.1-r2.ebuild
index be85f30bf70c..1e026315490c 100644
--- a/dev-lang/python/python-2.2.1-r2.ebuild
+++ b/dev-lang/python/python-2.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r2.ebuild,v 1.3 2002/07/21 00:54:59 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r2.ebuild,v 1.4 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -36,7 +36,7 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
diff --git a/dev-lang/python/python-2.2.1.ebuild b/dev-lang/python/python-2.2.1.ebuild
index d76d4bbf3fe3..395976365320 100644
--- a/dev-lang/python/python-2.2.1.ebuild
+++ b/dev-lang/python/python-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1.ebuild,v 1.4 2002/07/23 04:40:42 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1.ebuild,v 1.5 2002/08/02 04:44:54 seemant Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
@@ -35,21 +35,21 @@ src_compile() {
t=${S}/Makefile.pre.in
cp $t $t.orig || die
sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
- # turn **on** shared
+
+ # turn **on** shared
echo '*shared*' >> Modules/Setup.local
-
+
local myopts
#if we are creating a new build image, we remove the dependency on g++
if [ "`use build`" -a ! "`use bootstrap`" ]
then
myopts="--with-cxx=no"
fi
-
+
./configure \
--prefix=/usr \
--without-libdb \
- --with-fpectl \
+ --with-fpectl \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man $myopts || die
emake || die "Parallel make failed"
@@ -69,7 +69,7 @@ src_install() {
newexe ${FILESDIR}/python-config-${PYVER} python-config
# seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
+ # it probably shouldn't - use DistUtils, people!
insinto /usr/lib/python${PYVER}/config
doins ${S}/Makefile.pre.in