summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-05 06:16:38 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-05 06:16:38 +0000
commit316aec250de63e378de5b73d86cc014973410156 (patch)
treeda14d67b946046b356248afb99e03304883bb0c7 /dev-lang
parentportage-2.0.47_pre4 (diff)
downloadhistorical-316aec250de63e378de5b73d86cc014973410156.tar.gz
historical-316aec250de63e378de5b73d86cc014973410156.tar.bz2
historical-316aec250de63e378de5b73d86cc014973410156.zip
new package - gnu forth translator
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gforth/ChangeLog10
-rw-r--r--dev-lang/gforth/files/digest-gforth-0.5.01
-rw-r--r--dev-lang/gforth/gforth-0.5.0.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
new file mode 100644
index 000000000000..fa9f7fef1581
--- /dev/null
+++ b/dev-lang/gforth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/gforth
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.1 2003/01/05 06:16:38 george Exp $
+
+*gforth-0.5.0.ebuild (04 ñÎ× 2003)
+
+ 04 Jan 2003; George Shapovalov <george@gentoo.org> ChangeLog, gforth-0.5.0.ebuild, files/digest-gforth-0.5.0 :
+ initial release (#11677)
+ GNU Forth is a fast and portable implementation of the ANS Forth language
+ ebuild submitted by Rafael R. Sevilla <dido@imperium.ph>
diff --git a/dev-lang/gforth/files/digest-gforth-0.5.0 b/dev-lang/gforth/files/digest-gforth-0.5.0
new file mode 100644
index 000000000000..88f8603923f9
--- /dev/null
+++ b/dev-lang/gforth/files/digest-gforth-0.5.0
@@ -0,0 +1 @@
+MD5 db16b64e9d63934bc4455e9b2aebbe13 gforth-0.5.0.tar.gz 1472986
diff --git a/dev-lang/gforth/gforth-0.5.0.ebuild b/dev-lang/gforth/gforth-0.5.0.ebuild
new file mode 100644
index 000000000000..53ebf88cf4d8
--- /dev/null
+++ b/dev-lang/gforth/gforth-0.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.5.0.ebuild,v 1.1 2003/01/05 06:16:38 george Exp $
+
+IUSE=""
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Forth is a fast and portable implementation of the ANS Forth language"
+HOMEPAGE="http://www.gnu.org/software/gforth"
+SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Admittedly this should be UNSTABLE
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+# A lot of trouble with gcc3 and heavy opt flags, so let's try to dial
+# it down to -O1 at the most.
+strip-flags
+export CFLAGS="${CFLAGS//-O?} -O"
+
+src_compile() {
+ econf --enable-force-reg --without-debug || die "./configure failed"
+ # some configure flags that trip up gcc3.x are
+ # built into the thing. Get rid of the things.
+ cp Makefile Makefile.orig
+ sed -e "s:-O3::" Makefile.orig >Makefile
+ cp engine/Makefile engine/Makefile.orig
+ sed -e "s:-O3::" engine/Makefile.orig >engine/Makefile
+ emake XCFLAGS="" ENGINE_FLAGS="" || die
+}
+
+src_install () {
+ make install \
+ libdir=${D}/usr/lib \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ bindir=${D}/usr/bin \
+ install || die
+ dodoc AUTHORS README INSTALL NEWS doc/glossaries.doc gforth.ps
+}