summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-01-05 01:22:43 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-01-05 01:22:43 +0000
commitd484f78d5e8ae22121e4e214781b462efd35b6a3 (patch)
tree2ffd7c990803071fc7e9d3a45a6902979842ccb9 /dev-lang
parentVersion bump and removed all the older stuff (diff)
downloadhistorical-d484f78d5e8ae22121e4e214781b462efd35b6a3.tar.gz
historical-d484f78d5e8ae22121e4e214781b462efd35b6a3.tar.bz2
historical-d484f78d5e8ae22121e4e214781b462efd35b6a3.zip
Added lib64 patch
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/Manifest11
-rw-r--r--dev-lang/python/files/python-2.4-lib64.patch263
-rw-r--r--dev-lang/python/python-2.4.ebuild3
4 files changed, 276 insertions, 7 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index a83a379b3b90..ac33b216e04a 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.121 2005/01/05 00:38:48 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.122 2005/01/05 01:22:43 pythonhead Exp $
+
+ 04 Jan 2005; Rob Cakebread <pythonhead@gentoo.org>
+ +files/python-2.4-lib64.patch, python-2.4.ebuild:
+ Added lib64 patch
*python-2.4 (04 Jan 2005)
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index a13cb3e63420..1a562f76f5f0 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -1,10 +1,10 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 dbc9feab3262ca9536461c33958ee0fd ChangeLog 20747
+MD5 db33b850dcfc2007ad20932a74316387 ChangeLog 20873
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 b0dabb5b661c34b2054f5ae852c2fd45 python-2.1.3-r1.ebuild 2329
-MD5 06c1ad3f6bf19e785820e8f8154053f5 python-2.4.ebuild 6519
+MD5 273ffafb411b3058cfbecc13087041cf python-2.4.ebuild 6566
MD5 d646219175210ff5eec9a8996d2edb43 python-2.2.3-r5.ebuild 4311
MD5 3d174b1204c330f7cb067dbe6134fb73 python-2.3.3.ebuild 5571
MD5 79ce98d4e26ccecf872e428d3d7574af python-2.3.3-r1.ebuild 7019
@@ -40,10 +40,11 @@ MD5 2b953054102d344834597bc73b209e12 files/python-2.4-disable_modules_and_ssl.pa
MD5 2121d3986faa4b6c2c3ed472f77f2a9d files/python-2.4-gentoo_py_dontcompile.patch 477
MD5 ec16631b538a7481f0537191d5f23b27 files/python-2.4-mimetypes_apache.patch 454
MD5 d74e7f0fd47f00e8b3fe7ca36b7eb629 files/python-config-2.4 179
+MD5 a387f41bfc6767b90a51daaa0c0aac45 files/python-2.4-lib64.patch 11779
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFB2zc7z2gxt1z4IGYRAi3SAJ9LF0IaHn9ls27gBxWEblMD9yyr+gCg1PF5
-3TZ9tec9i0V+0E19krQpVKE=
-=gzYA
+iD8DBQFB20GGz2gxt1z4IGYRAl0CAKCme1dTUoHKyD5MMUA8lT85fzvuCQCgwFFM
+04kLUg9p4vDlZ4pweLQsUDU=
+=OxBt
-----END PGP SIGNATURE-----
diff --git a/dev-lang/python/files/python-2.4-lib64.patch b/dev-lang/python/files/python-2.4-lib64.patch
new file mode 100644
index 000000000000..c2b37feb4946
--- /dev/null
+++ b/dev-lang/python/files/python-2.4-lib64.patch
@@ -0,0 +1,263 @@
+diff -Nru Python-2.3.4.old/Lib/distutils/command/install.py Python-2.3.4/Lib/distutils/command/install.py
+--- Python-2.3.4.old/Lib/distutils/command/install.py 2004-08-14 21:38:57.318696000 -0400
++++ Python-2.3.4/Lib/distutils/command/install.py 2004-08-14 21:39:41.285012104 -0400
+@@ -39,14 +39,14 @@
+ INSTALL_SCHEMES = {
+ 'unix_prefix': {
+ 'purelib': '$base/lib/python$py_version_short/site-packages',
+- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
++ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
+ 'headers': '$base/include/python$py_version_short/$dist_name',
+ 'scripts': '$base/bin',
+ 'data' : '$base',
+ },
+ 'unix_home': {
+ 'purelib': '$base/lib/python',
+- 'platlib': '$base/lib/python',
++ 'platlib': '$base/lib64/python',
+ 'headers': '$base/include/python/$dist_name',
+ 'scripts': '$base/bin',
+ 'data' : '$base',
+diff -Nru Python-2.3.4.old/Lib/distutils/sysconfig.py Python-2.3.4/Lib/distutils/sysconfig.py
+--- Python-2.3.4.old/Lib/distutils/sysconfig.py 2004-08-14 21:38:57.367688552 -0400
++++ Python-2.3.4/Lib/distutils/sysconfig.py 2004-08-14 21:39:41.300009824 -0400
+@@ -99,8 +99,12 @@
+ prefix = plat_specific and EXEC_PREFIX or PREFIX
+
+ if os.name == "posix":
++ if plat_specific or standard_lib:
++ lib = "lib64"
++ else:
++ lib = "lib"
+ libpython = os.path.join(prefix,
+- "lib", "python" + get_python_version())
++ lib, "python" + get_python_version())
+ if standard_lib:
+ return libpython
+ else:
+diff -Nru Python-2.3.4.old/Lib/site.py Python-2.3.4/Lib/site.py
+--- Python-2.3.4.old/Lib/site.py 2004-08-14 21:38:57.565658456 -0400
++++ Python-2.3.4/Lib/site.py 2004-08-14 21:39:41.318007088 -0400
+@@ -166,9 +166,14 @@
+ sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
+ elif os.sep == '/':
+ sitedirs = [os.path.join(prefix,
++ "lib64",
++ "python" + sys.version[:3],
++ "site-packages"),
++ os.path.join(prefix,
+ "lib",
+ "python" + sys.version[:3],
+ "site-packages"),
++ os.path.join(prefix, "lib64", "site-python"),
+ os.path.join(prefix, "lib", "site-python")]
+ else:
+ sitedirs = [prefix, os.path.join(prefix, "lib", "site-packages")]
+diff -Nru Python-2.3.4.old/Lib/test/test_re.py Python-2.3.4/Lib/test/test_re.py
+--- Python-2.3.4.old/Lib/test/test_re.py 2004-08-14 21:38:56.631800424 -0400
++++ Python-2.3.4/Lib/test/test_re.py 2004-08-14 21:39:34.240083096 -0400
+@@ -497,6 +497,15 @@
+ self.assert_(re.compile('bug_926075') is not
+ re.compile(eval("u'bug_926075'")))
+
++ def test_bug_931848(self):
++ try:
++ unicode
++ except NameError:
++ pass
++ pattern = eval('u"[\u002E\u3002\uFF0E\uFF61]"')
++ self.assertEqual(re.compile(pattern).split("a.b.c"),
++ ['a','b','c'])
++
+ def run_re_tests():
+ from test.re_tests import benchmarks, tests, SUCCEED, FAIL, SYNTAX_ERROR
+ if verbose:
+diff -Nru Python-2.3.4.old/Makefile.pre.in Python-2.3.4/Makefile.pre.in
+--- Python-2.3.4.old/Makefile.pre.in 2004-08-14 21:39:00.506211424 -0400
++++ Python-2.3.4/Makefile.pre.in 2004-08-14 21:39:41.341003592 -0400
+@@ -79,11 +79,11 @@
+
+ # Expanded directories
+ BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++LIBDIR= $(exec_prefix)/lib64
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
+-SCRIPTDIR= $(prefix)/lib
++SCRIPTDIR= $(prefix)/lib64
+
+ # Detailed destination directories
+ BINLIBDEST= $(LIBDIR)/python$(VERSION)
+diff -Nru Python-2.3.4.old/Modules/Setup.dist Python-2.3.4/Modules/Setup.dist
+--- Python-2.3.4.old/Modules/Setup.dist 2004-08-14 21:39:00.761172664 -0400
++++ Python-2.3.4/Modules/Setup.dist 2004-08-14 21:42:09.073544832 -0400
+@@ -343,7 +343,7 @@
+ # *** Uncomment and edit to reflect your Tcl/Tk versions:
+ # -ltk8.2 -ltcl8.2 \
+ # *** Uncomment and edit to reflect where your X11 libraries are:
+-# -L/usr/X11R6/lib \
++ -L/usr/X11R6/lib64 \
+ # *** Or uncomment this for Solaris:
+ # -L/usr/openwin/lib \
+ # *** Uncomment these for TOGL extension only:
+@@ -417,7 +417,7 @@
+ #DB=/usr/local/BerkeleyDB.4.0
+ #DBLIBVER=4.0
+ #DBINC=$(DB)/include
+-#DBLIB=$(DB)/lib
++DBLIB=$(DB)/lib64
+ #_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
+
+ # Historical Berkeley DB 1.85
+@@ -463,7 +463,7 @@
+ # Andrew Kuchling's zlib module.
+ # This require zlib 1.1.3 (or later).
+ # See http://www.cdrom.com/pub/infozip/zlib/
+-#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
++zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib64 -lz
+
+ # Interface to the Expat XML parser
+ #
+diff -Nru Python-2.3.4.old/Modules/getpath.c Python-2.3.4/Modules/getpath.c
+--- Python-2.3.4.old/Modules/getpath.c 2004-08-14 21:39:00.750174336 -0400
++++ Python-2.3.4/Modules/getpath.c 2004-08-14 21:39:41.319006936 -0400
+@@ -112,8 +112,8 @@
+ #endif
+
+ #ifndef PYTHONPATH
+-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
+- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
++#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
++ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
+ #endif
+
+ #ifndef LANDMARK
+@@ -124,7 +124,7 @@
+ static char exec_prefix[MAXPATHLEN+1];
+ static char progpath[MAXPATHLEN+1];
+ static char *module_search_path = NULL;
+-static char lib_python[] = "lib/python" VERSION;
++static char lib_python[] = "lib64/python" VERSION;
+
+ static void
+ reduce(char *dir)
+@@ -492,7 +492,7 @@
+ }
+ else
+ strncpy(zip_path, PREFIX, MAXPATHLEN);
+- joinpath(zip_path, "lib/python00.zip");
++ joinpath(zip_path, "lib64/python00.zip");
+ bufsz = strlen(zip_path); /* Replace "00" with version */
+ zip_path[bufsz - 6] = VERSION[0];
+ zip_path[bufsz - 5] = VERSION[2];
+@@ -502,7 +502,7 @@
+ fprintf(stderr,
+ "Could not find platform dependent libraries <exec_prefix>\n");
+ strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
+- joinpath(exec_prefix, "lib/lib-dynload");
++ joinpath(exec_prefix, "lib64/lib-dynload");
+ }
+ /* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
+
+diff -Nru Python-2.3.4.old/setup.py Python-2.3.4/setup.py
+--- Python-2.3.4.old/setup.py 2004-08-14 21:39:00.575200936 -0400
++++ Python-2.3.4/setup.py 2004-08-14 21:39:41.340003744 -0400
+@@ -241,7 +241,7 @@
+
+ def detect_modules(self):
+ # Ensure that /usr/local is always used
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+
+ # fink installs lots of goodies in /sw/... - make sure we
+@@ -264,7 +264,7 @@
+ # lib_dirs and inc_dirs are used to search for files;
+ # if a file is found in one of those directories, it can
+ # be assumed that no additional -I,-L directives are needed.
+- lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib']
++ lib_dirs = self.compiler.library_dirs + ['/lib64', '/usr/lib64']
+ inc_dirs = self.compiler.include_dirs + ['/usr/include']
+ exts = []
+
+@@ -413,11 +413,11 @@
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):
+ readline_libs.append('curses')
+ elif self.compiler.find_library_file(lib_dirs +
+- ['/usr/lib/termcap'],
++ ['/usr/lib64/termcap'],
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib64/termcap'],
+ libraries=readline_libs) )
+ if platform not in ['mac']:
+ # crypt module.
+@@ -446,8 +446,8 @@
+ if krb5_h:
+ ssl_incs += krb5_h
+ ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
+- ['/usr/local/ssl/lib',
+- '/usr/contrib/ssl/lib/'
++ ['/usr/local/ssl/lib64',
++ '/usr/contrib/ssl/lib64/'
+ ] )
+
+ if (ssl_incs is not None and
+@@ -481,12 +481,12 @@
+ # order you wish to search - e.g., search for db4 before db3
+ db_try_this = {
+ 'db4': {'libs': ('db-4.2', 'db42', 'db-4.1', 'db41', 'db-4.0', 'db4',),
+- 'libdirs': ('/usr/local/BerkeleyDB.4.2/lib',
+- '/usr/local/BerkeleyDB.4.1/lib',
+- '/usr/local/BerkeleyDB.4.0/lib',
+- '/usr/local/lib',
++ 'libdirs': ('/usr/local/BerkeleyDB.4.2/lib64',
++ '/usr/local/BerkeleyDB.4.1/lib64',
++ '/usr/local/BerkeleyDB.4.0/lib64',
++ '/usr/local/lib64',
+ '/opt/sfw',
+- '/sw/lib',
++ '/sw/lib64',
+ ),
+ 'incdirs': ('/usr/local/BerkeleyDB.4.2/include',
+ '/usr/local/include/db42',
+@@ -499,12 +499,12 @@
+ '/usr/include/db4',
+ )},
+ 'db3': {'libs': ('db-3.3', 'db-3.2', 'db-3.1', 'db3',),
+- 'libdirs': ('/usr/local/BerkeleyDB.3.3/lib',
+- '/usr/local/BerkeleyDB.3.2/lib',
+- '/usr/local/BerkeleyDB.3.1/lib',
+- '/usr/local/lib',
+- '/opt/sfw/lib',
+- '/sw/lib',
++ 'libdirs': ('/usr/local/BerkeleyDB.3.3/lib64',
++ '/usr/local/BerkeleyDB.3.2/lib64',
++ '/usr/local/BerkeleyDB.3.1/lib64',
++ '/usr/local/lib64',
++ '/opt/sfw/lib64',
++ '/sw/lib64',
+ ),
+ 'incdirs': ('/usr/local/BerkeleyDB.3.3/include',
+ '/usr/local/BerkeleyDB.3.2/include',
+@@ -986,14 +986,14 @@
+ added_lib_dirs.append('/usr/openwin/lib')
+ elif os.path.exists('/usr/X11R6/include'):
+ include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib')
++ added_lib_dirs.append('/usr/X11R6/lib64')
+ elif os.path.exists('/usr/X11R5/include'):
+ include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
++ added_lib_dirs.append('/usr/X11R5/lib64')
+ else:
+ # Assume default location for X11
+ include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
++ added_lib_dirs.append('/usr/X11/lib64')
+
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
diff --git a/dev-lang/python/python-2.4.ebuild b/dev-lang/python/python-2.4.ebuild
index ed89aa78ff87..09adce6905db 100644
--- a/dev-lang/python/python-2.4.ebuild
+++ b/dev-lang/python/python-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.ebuild,v 1.1 2005/01/05 00:38:48 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.ebuild,v 1.2 2005/01/05 01:22:43 pythonhead Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -54,6 +54,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-${PYVER}-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-${PYVER}-mimetypes_apache.patch
epatch ${FILESDIR}/${PN}-${PYVER}-db4.2.patch
+ epatch ${FILESDIR}/${PN}-${PYVER}-lib64.patch
}
src_configure() {