summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-31 08:12:06 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-31 08:12:06 +0000
commit4734b2830f6470c160c7b2c4cce56c8203ba4f64 (patch)
tree99ff967187dadbb4c277a58dbe19fe1acdda12d2 /dev-libs/apr-util/files
parentSimplify src_compile/src_install a bit -- no functional changes. (diff)
downloadhistorical-4734b2830f6470c160c7b2c4cce56c8203ba4f64.tar.gz
historical-4734b2830f6470c160c7b2c4cce56c8203ba4f64.tar.bz2
historical-4734b2830f6470c160c7b2c4cce56c8203ba4f64.zip
Utilize SYSROOT to locate build-time paths when cross-compiling, and drop redundent -L/-R libdir flags to simplify linking. Rewrite build/rules.mk to pick up current env settings rather than clobbering at make time. #385775 by Bertrand Jacquin.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xD2E96200
Diffstat (limited to 'dev-libs/apr-util/files')
-rw-r--r--dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch b/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch
new file mode 100644
index 000000000000..ce07b1470525
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/385775
+
+utilize $SYSROOT to find the right includedir tree
+
+drop the -L/-R paths since we know our libdir is the standard path which
+the compiler already knows how to locate
+
+--- a/apu-config.in
++++ b/apu-config.in
+@@ -25,7 +25,7 @@ prefix="@prefix@"
+ exec_prefix="@exec_prefix@"
+ bindir="@bindir@"
+ libdir="@libdir@"
+-includedir="@includedir@"
++includedir="${SYSROOT}@includedir@"
+
+ LIBS="@APRUTIL_EXPORT_LIBS@"
+ INCLUDES="@APRUTIL_INCLUDES@"
+@@ -166,7 +166,7 @@ while test $# -gt 0; do
+ --link-ld)
+ if test "$location" = "installed"; then
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+- flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
++ flags="$flags -l$APRUTIL_LIBNAME"
+ else
+ flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
+ fi
+@@ -182,7 +182,7 @@ while test $# -gt 0; do
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+ # Since the user is specifying they are linking with libtool, we
+ # *know* that -R will be recognized by libtool.
+- flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
++ flags="$flags -l$APRUTIL_LIBNAME"
+ else
+ flags="$flags $LA_FILE"
+ fi