summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-09-06 18:38:13 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-09-06 18:38:13 +0000
commitfdc02ddc5c9834bb0bd38fc115f89675c70d0aa3 (patch)
treebc82ff0bf2e5d3d184c325aabeb564bd86573827 /dev-libs/atk/atk-1.10.3.ebuild
parentStable on ppc64 (diff)
downloadhistorical-fdc02ddc5c9834bb0bd38fc115f89675c70d0aa3.tar.gz
historical-fdc02ddc5c9834bb0bd38fc115f89675c70d0aa3.tar.bz2
historical-fdc02ddc5c9834bb0bd38fc115f89675c70d0aa3.zip
New release: 1.10.3
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-libs/atk/atk-1.10.3.ebuild')
-rw-r--r--dev-libs/atk/atk-1.10.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/atk/atk-1.10.3.ebuild b/dev-libs/atk/atk-1.10.3.ebuild
new file mode 100644
index 000000000000..e181bfe67c31
--- /dev/null
+++ b/dev-libs/atk/atk-1.10.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.10.3.ebuild,v 1.1 2005/09/06 18:38:13 leonardop Exp $
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc static"
+
+RDEPEND=">=dev-libs/glib-2.5.7"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_enable static)"
+}
+
+#src_unpack() {
+# unpack "${A}"
+# cd "${S}"
+
+ # Re-generate ltmain.sh, configure and friends, since the upstream tarball
+ # was built with a buggy libtool (missing 'so' extension in binaries).
+# export WANT_AUTOMAKE=1.7
+# libtoolize --copy --force
+ # Preserve gtk-doc macro
+# sed -n -e '/GTK_DOC_CHECK/,$p' aclocal.m4 > gtkdoc.m4
+# aclocal -I . || die "aclocal failed"
+# autoconf || die "autoconf failed"
+#}