summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2014-05-22 12:57:16 +0000
committerRyan Hill <rhill@gentoo.org>2014-05-22 12:57:16 +0000
commitb1f355b95d8372ad14180e4eb653022779fe8018 (patch)
tree66a86f85e3c80651d728db19e7dedb7f4a9c23c4 /dev-libs/cloog/cloog-0.18.1.ebuild
parentVersion bump (bug #467192). Use EAPI 5 and add subslots. Add multilib (diff)
downloadhistorical-b1f355b95d8372ad14180e4eb653022779fe8018.tar.gz
historical-b1f355b95d8372ad14180e4eb653022779fe8018.tar.bz2
historical-b1f355b95d8372ad14180e4eb653022779fe8018.zip
Version bump (bug #491726). USE EAPI 5 and subslots. Add multilib support.
Add missing pkgconfig dep. Remove old. Signed-off-by: Ryan Hill <rhill@gentoo.org> Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x957A8463
Diffstat (limited to 'dev-libs/cloog/cloog-0.18.1.ebuild')
-rw-r--r--dev-libs/cloog/cloog-0.18.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/cloog/cloog-0.18.1.ebuild b/dev-libs/cloog/cloog-0.18.1.ebuild
new file mode 100644
index 000000000000..040d9ade3080
--- /dev/null
+++ b/dev-libs/cloog/cloog-0.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/cloog-0.18.1.ebuild,v 1.1 2014/05/22 12:57:15 rhill Exp $
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/index.php"
+SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.0.2[${MULTILIB_USEDEP}]
+ dev-libs/isl:0/10[${MULTILIB_USEDEP}]
+ !<dev-libs/cloog-ppl-0.15.10"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_prepare() {
+ # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
+ # sed to avoid eautoreconf
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-gmp=system \
+ --with-isl=system \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}