summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-04 21:07:45 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-04 21:07:45 +0000
commit6201422e60f4bc68de19e1d00e6a733037dea6f7 (patch)
tree320c54ca2602f62f30669d6ec1615d9f9d7d0076 /dev-libs/fcgi/fcgi-2.4.0.ebuild
parentinitial import. (future dependency of clisp) (diff)
downloadhistorical-6201422e60f4bc68de19e1d00e6a733037dea6f7.tar.gz
historical-6201422e60f4bc68de19e1d00e6a733037dea6f7.tar.bz2
historical-6201422e60f4bc68de19e1d00e6a733037dea6f7.zip
initial import. (future dependency of clisp)
Diffstat (limited to 'dev-libs/fcgi/fcgi-2.4.0.ebuild')
-rw-r--r--dev-libs/fcgi/fcgi-2.4.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/fcgi/fcgi-2.4.0.ebuild b/dev-libs/fcgi/fcgi-2.4.0.ebuild
new file mode 100644
index 000000000000..5bc877030b4d
--- /dev/null
+++ b/dev-libs/fcgi/fcgi-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.0.ebuild,v 1.1 2003/09/04 21:07:42 mkennedy Exp $
+
+DESCRIPTION="FastCGI Developer's Kit"
+HOMEPAGE="http://www.fastcgi.com/"
+SRC_URI="HTTP://www.fastcgi.com/dist/${P}.tar.gz"
+LICENSE="FastCGI"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc LICENSE.TERMS README
+ dohtml doc/*
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.c
+ insinto /usr/share/doc/${P}/images
+ doins images/*
+}