summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
commit3bec718764ff9ac07369bd757a46bef08e73b11f (patch)
tree575bcf9af303123f19cc3ea6ca71c66455f70ae6 /dev-libs/glib
parentUpdates (diff)
downloadhistorical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.gz
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.bz2
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.zip
Updates and forgotten files
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-1.2.9.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-1.2.9.ebuild b/dev-libs/glib/glib-1.2.9.ebuild
new file mode 100644
index 000000000000..12e1f797d3b0
--- /dev/null
+++ b/dev-libs/glib/glib-1.2.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.9.ebuild,v 1.1 2001/03/06 06:20:41 achim Exp $
+
+# also, this script now has pre/post inst/rm support
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/"${A}
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-threads=posix ${myconf}
+ try make
+
+}
+
+src_install() {
+
+ try make install prefix=${D}/usr infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+ cd docs
+ docinto html
+ dodoc glib.html glib_toc.html
+
+}
+
+
+
+
+