summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-11-10 00:08:17 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-11-10 00:08:17 +0000
commit820b838bfbaa2ae77a0902de877bea7ab03a374c (patch)
tree39ef8d6e2814e8300fbce5598099beaaa1b808a4 /dev-libs/gmime/gmime-2.1.9-r1.ebuild
parentFixed digests and closing bug #70611. (diff)
downloadhistorical-820b838bfbaa2ae77a0902de877bea7ab03a374c.tar.gz
historical-820b838bfbaa2ae77a0902de877bea7ab03a374c.tar.bz2
historical-820b838bfbaa2ae77a0902de877bea7ab03a374c.zip
Prefix uuencode and uudecode with gmime- to prevent file collision. Closes #70392.
Diffstat (limited to 'dev-libs/gmime/gmime-2.1.9-r1.ebuild')
-rw-r--r--dev-libs/gmime/gmime-2.1.9-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/gmime/gmime-2.1.9-r1.ebuild b/dev-libs/gmime/gmime-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..7619e4cecada
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.1.9-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.1.9-r1.ebuild,v 1.1 2004/11/10 00:08:17 ticho Exp $
+
+inherit gnome2 eutils
+
+IUSE="doc ipv6"
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+SRC_URI="http://spruce.sourceforge.net/gmime/sources/v${PV%.*}/${P}.tar.gz"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+DEPEND="dev-util/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html:g' \
+ docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
+ || die "sed failed (1)"
+}
+
+src_compile() {
+ econf \
+ `use_enable ipv6` \
+ `use_enable doc gtk-doc` || die "configure failed"
+}
+
+pkg_preinst() {
+ # rename these two, so they don't conflict with app-arch/sharutils
+ # (bug #70392) Ticho, 2004-11-10
+ mv ${D}/usr/bin/uuencode ${D}/usr/bin/gmime-uuencode
+ mv ${D}/usr/bin/uudecode ${D}/usr/bin/gmime-uudecode
+}
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"