summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-01-12 17:50:23 +0000
committerDane Smith <c1pher@gentoo.org>2011-01-12 17:50:23 +0000
commit48de7bb078703de356d182a1df5ab871ae8e4750 (patch)
treec82ef205df8dc0acf4692c395c227d7a53e799a0 /dev-libs/libassuan/libassuan-2.0.1.ebuild
parentBump to 0.10.31. No changes since 0.10.30. (diff)
downloadhistorical-48de7bb078703de356d182a1df5ab871ae8e4750.tar.gz
historical-48de7bb078703de356d182a1df5ab871ae8e4750.tar.bz2
historical-48de7bb078703de356d182a1df5ab871ae8e4750.zip
Version bump for dev-libs/libassuan. Bug 351442.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux i686
Diffstat (limited to 'dev-libs/libassuan/libassuan-2.0.1.ebuild')
-rw-r--r--dev-libs/libassuan/libassuan-2.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/libassuan/libassuan-2.0.1.ebuild b/dev-libs/libassuan/libassuan-2.0.1.ebuild
new file mode 100644
index 000000000000..91d3ce086564
--- /dev/null
+++ b/dev-libs/libassuan/libassuan-2.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libassuan/libassuan-2.0.1.ebuild,v 1.1 2011/01/12 17:50:23 c1pher Exp $
+
+EAPI="2"
+
+DESCRIPTION="IPC library used by GnuPG and GPGME"
+HOMEPAGE="http://www.gnupg.org/related_software/libassuan/index.en.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/libgpg-error-1.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}