summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-04-30 23:16:43 +0000
committerTristan Heaven <tristan@gentoo.org>2008-04-30 23:16:43 +0000
commit8fd3b08ca72898a1841207986aa585964454602a (patch)
treec5374cd82acf27f95a871c81b7315c038d47d48e /dev-libs/libbulletml/libbulletml-0.0.6.ebuild
parentFix building with gcc-4.3 (diff)
downloadhistorical-8fd3b08ca72898a1841207986aa585964454602a.tar.gz
historical-8fd3b08ca72898a1841207986aa585964454602a.tar.bz2
historical-8fd3b08ca72898a1841207986aa585964454602a.zip
Fix building with gcc-4.3
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'dev-libs/libbulletml/libbulletml-0.0.6.ebuild')
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
index 1493acd27704..d6f003cc8d33 100644
--- a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.5 2005/08/11 12:01:55 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.6 2008/04/30 23:16:43 nyhm Exp $
+
+inherit eutils
DESCRIPTION="A Library of Bullet Markup Language"
HOMEPAGE="http://user.ecc.u-tokyo.ac.jp/~s31552/wp/libbulletml/index_en.html"
@@ -13,21 +15,27 @@ IUSE=""
S="${WORKDIR}/${PN#lib}/src"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "emake failed"
}
src_install() {
- dolib.a libbulletml.a
+ dolib.a libbulletml.a || die "dolib.a failed"
insinto /usr/include/bulletml
- doins *.h
+ doins *.h || die "doins .h failed"
insinto /usr/include/bulletml/tinyxml
- doins tinyxml/tinyxml.h
+ doins tinyxml/tinyxml.h || die "doins tinyxml.h failed"
insinto /usr/include/bulletml/ygg
- doins ygg/ygg.h
+ doins ygg/ygg.h || die "doins ygg.h failed"
dodoc ../README*
}