summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-04-23 14:05:00 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-04-23 14:05:00 +0000
commit8d2c125cb7a1d8c1d5778875e5bef3069e63c9cd (patch)
tree0a0bd3815b5f6c26d93e11f2d06141c0e7c99f9d /dev-libs/libee/libee-0.3.2-r2.ebuild
parentVersion bump: 7.3.502 is released (diff)
downloadhistorical-8d2c125cb7a1d8c1d5778875e5bef3069e63c9cd.tar.gz
historical-8d2c125cb7a1d8c1d5778875e5bef3069e63c9cd.tar.bz2
historical-8d2c125cb7a1d8c1d5778875e5bef3069e63c9cd.zip
Add 0.4.1 with fix for #409137 and 0.3.2-r2 with backported patch from 0.4.1 for the same bug. Thanks to slepnoga
Package-Manager: portage-2.1.10.57/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libee/libee-0.3.2-r2.ebuild')
-rw-r--r--dev-libs/libee/libee-0.3.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libee/libee-0.3.2-r2.ebuild b/dev-libs/libee/libee-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..93a44d39081c
--- /dev/null
+++ b/dev-libs/libee/libee-0.3.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/libee-0.3.2-r2.ebuild,v 1.1 2012/04/23 14:05:00 maksbotan Exp $
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="An Event Expression Library inspired by CEE"
+HOMEPAGE="http://www.libee.org"
+SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libestr"
+RDEPEND="${DEPEND}"
+
+DOCS=(INSTALL ChangeLog)
+PATCHES=("${FILESDIR}"/0.3.2-add_math_lib_configure.patch
+"${FILESDIR}"/0.3.2-add_math_lib_pc_in.patch)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ --enable-testbench
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+}