summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-08-20 09:05:53 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-08-20 09:05:53 +0000
commitbfa2c2e094f49b3767849d141a317663c3d48e92 (patch)
tree2f50723a26ddf9ffb84d3ffa460481882448291c /dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild
parentRemoving a few masks for removed packages. (diff)
downloadhistorical-bfa2c2e094f49b3767849d141a317663c3d48e92.tar.gz
historical-bfa2c2e094f49b3767849d141a317663c3d48e92.tar.bz2
historical-bfa2c2e094f49b3767849d141a317663c3d48e92.zip
revision bump to force pic static libraries (bug #96022)
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..45c695bd3885
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.1-r1.ebuild,v 1.1 2005/08/20 09:05:53 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="dev-libs/libgpg-error"
+RDEPEND="nls? ( sys-devel/gettext )
+ dev-libs/libgpg-error"
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+}
+
+src_compile() {
+ econf $(use_enable nls) --disable-dependency-tracking --with-pic || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+
+ # backwards compat symlinks
+ if use ppc-macos ; then
+ dosym libgcrypt.11.dylib /usr/lib/libgcrypt.7.dylib
+ else
+ dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
+ fi
+}