summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-07-02 12:33:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-07-02 12:33:59 +0000
commite16e6fe146a920a6f5a622023b654eff16307b86 (patch)
tree50e201dfdd67f55cbe96f9dd53ffe532b0d3ef41 /dev-libs/liboil/liboil-0.3.15.ebuild
parentx11-drivers/xf86-video-i810: clean up old releases (diff)
downloadhistorical-e16e6fe146a920a6f5a622023b654eff16307b86.tar.gz
historical-e16e6fe146a920a6f5a622023b654eff16307b86.tar.bz2
historical-e16e6fe146a920a6f5a622023b654eff16307b86.zip
Version bump.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64
Diffstat (limited to 'dev-libs/liboil/liboil-0.3.15.ebuild')
-rw-r--r--dev-libs/liboil/liboil-0.3.15.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/liboil/liboil-0.3.15.ebuild b/dev-libs/liboil/liboil-0.3.15.ebuild
new file mode 100644
index 000000000000..2436e2e19879
--- /dev/null
+++ b/dev-libs/liboil/liboil-0.3.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liboil/liboil-0.3.15.ebuild,v 1.1 2008/07/02 12:33:59 drac Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="library of simple functions that are optimized for various CPUs"
+HOMEPAGE="http://liboil.freedesktop.org/"
+SRC_URI="http://liboil.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="=dev-libs/glib-2*"
+
+src_compile() {
+ strip-flags
+ filter-flags -O?
+ append-flags -O2
+ econf --disable-dependency-tracking \
+ $(use_enable doc gtk-doc) || die "econf failed."
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUG-REPORTING HACKING NEWS README
+}