summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjoern Brauel <bjb@gentoo.org>2002-12-15 15:18:04 +0000
committerBjoern Brauel <bjb@gentoo.org>2002-12-15 15:18:04 +0000
commita15b2378f27043dd7f7df0a2ab9ae66124ca1fab (patch)
tree86c9500fc16fad75f0e82ad76087164b3a0ad968 /dev-libs/libots
parentadd initial ebuild for the compaq alpha jdk 1.3.1 (diff)
downloadhistorical-a15b2378f27043dd7f7df0a2ab9ae66124ca1fab.tar.gz
historical-a15b2378f27043dd7f7df0a2ab9ae66124ca1fab.tar.bz2
historical-a15b2378f27043dd7f7df0a2ab9ae66124ca1fab.zip
initial ebuild of libots. Required for compaq-jdk/jre on alpha
Diffstat (limited to 'dev-libs/libots')
-rw-r--r--dev-libs/libots/ChangeLog8
-rw-r--r--dev-libs/libots/files/digest-libots-2.2.70
-rw-r--r--dev-libs/libots/libots-2.2.7.ebuild32
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libots/ChangeLog b/dev-libs/libots/ChangeLog
new file mode 100644
index 000000000000..386b6e8b0800
--- /dev/null
+++ b/dev-libs/libots/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/compaq-jdk
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/ChangeLog,v 1.1 2002/12/15 15:18:04 bjb Exp $
+
+*libots-2.2.7 (15 Dec 2002)
+ 15 Dec 2002; Bjoern Brauel <bjb@gentoo.org>
+ Initial ebuild
+
diff --git a/dev-libs/libots/files/digest-libots-2.2.7 b/dev-libs/libots/files/digest-libots-2.2.7
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-libs/libots/files/digest-libots-2.2.7
diff --git a/dev-libs/libots/libots-2.2.7.ebuild b/dev-libs/libots/libots-2.2.7.ebuild
new file mode 100644
index 000000000000..eff27aa23263
--- /dev/null
+++ b/dev-libs/libots/libots-2.2.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/libots-2.2.7.ebuild,v 1.1 2002/12/15 15:18:04 bjb Exp $
+
+At="libots-2.2.7-2.alpha.rpm"
+S=${WORKDIR}/usr/lib/compaq/libots-2.2.7
+SRC_URI=""
+DESCRIPTION="Compaq Linux optimized runtime for Alpha/Linux/GNU"
+HOMEPAGE="http://h18012.www1.hp.com/java/documentation/1.3.1/linux/docs/index.html"
+DEPEND="virtual/glibc
+ app-arch/rpm2targz "
+RDEPEND="$DEPEND"
+LICENSE="compaq-sdla"
+SLOT="2.2.7"
+KEYWORDS="-x86 -ppc -sparc alpha"
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE}"
+ fi
+ rpm2targz ${DISTDIR}/${At}
+ tar zxf libots-2.2.7-2.alpha.tar.gz
+}
+
+src_install () {
+ dodir /usr/lib
+
+ cp libots.* ${D}/usr/lib
+
+ dodoc README
+}
+