summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-02 06:47:25 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-02 06:47:25 +0000
commit2bdae50f810586f251528e1025dd058a8486f3b2 (patch)
tree51c412d67b13cf0a775ac72c8026ac1fde67f9f1 /dev-libs/rasqal/rasqal-0.9.12.ebuild
parentVersion bump. (diff)
downloadhistorical-2bdae50f810586f251528e1025dd058a8486f3b2.tar.gz
historical-2bdae50f810586f251528e1025dd058a8486f3b2.tar.bz2
historical-2bdae50f810586f251528e1025dd058a8486f3b2.zip
Version bump and fix some typos #137532 by Joe Button.
Package-Manager: portage-2.1.1_pre1-r5
Diffstat (limited to 'dev-libs/rasqal/rasqal-0.9.12.ebuild')
-rw-r--r--dev-libs/rasqal/rasqal-0.9.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/rasqal/rasqal-0.9.12.ebuild b/dev-libs/rasqal/rasqal-0.9.12.ebuild
new file mode 100644
index 000000000000..643ecbbe8750
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.12.ebuild,v 1.1 2006/07/02 06:47:25 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre xml"
+
+RDEPEND="sys-devel/flex
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ >=media-libs/raptor-1.4.9"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-typos.patch
+}
+
+src_compile() {
+ local regexlib
+ use pcre && regexlib="pcre" || regexlib="posix"
+ econf \
+ $(use_with pcre pcre-config) \
+ $(use_with xml xml2-config) \
+ --with-regex-library=${regexlib} \
+ --with-raptor=system \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS NEWS README
+}