summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-04-20 13:43:11 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-04-20 13:43:11 +0000
commite390165a677d858d35c40f4fb4bcbaadbb9c4494 (patch)
tree7789371e5a7f6bff37275399d3c4b71a5b5e4a11 /dev-libs/root/root-3.10.02.ebuild
parent~amd64 (diff)
downloadhistorical-e390165a677d858d35c40f4fb4bcbaadbb9c4494.tar.gz
historical-e390165a677d858d35c40f4fb4bcbaadbb9c4494.tar.bz2
historical-e390165a677d858d35c40f4fb4bcbaadbb9c4494.zip
Version bump, see bug #34412
Diffstat (limited to 'dev-libs/root/root-3.10.02.ebuild')
-rw-r--r--dev-libs/root/root-3.10.02.ebuild163
1 files changed, 163 insertions, 0 deletions
diff --git a/dev-libs/root/root-3.10.02.ebuild b/dev-libs/root/root-3.10.02.ebuild
new file mode 100644
index 000000000000..e14710acf4ab
--- /dev/null
+++ b/dev-libs/root/root-3.10.02.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.10.02.ebuild,v 1.1 2004/04/20 13:43:11 phosphan Exp $
+
+inherit flag-o-matic eutils
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="An Object-Oriented Data Analysis Framework"
+SRC_URI="ftp://root.cern.ch/root/root_v${PV}.source.tar.gz"
+HOMEPAGE="http://root.cern.ch/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+IUSE="mysql postgres opengl afs kerberos ldap qt"
+
+DEPEND="virtual/x11
+ >=media-libs/freetype-2.0.9
+ sys-apps/shadow
+ opengl? ( virtual/opengl virtual/glu )
+ mysql? ( >=dev-db/mysql-3.23.49 )
+ postgres? ( >=dev-db/postgresql-7.1.3-r4 )
+ afs? ( net-fs/openafs )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ qt? ( x11-libs/qt )"
+
+src_compile() {
+ if [ "x$CERNLIB" = "x" ]
+ then
+ einfo "No support for cernlib, (h/g)2root will not be build."
+ einfo "To install root with cernlib support, use:"
+ einfo " export CERNLIB=<directory>/lib"
+ einfo "where <directory>/lib contains libpacklib.[so,a] and libkernlib.[so,a]"
+ USECERN="--disable-cern"
+ else
+ if [ -e $CERNLIB/libpacklib.[so,a] -a -e $CERNLIB/libkernlib.[so,a] ]
+ then
+ einfo "Support for cernlib found."
+ USECERN="--enable-cern --with-cern-libdir=$CERNLIB"
+ else
+ einfo "No support for cernlib, (h/g)2root will not be build."
+ einfo "CERNLIB = $CERNLIB has no libpacklib.[so,a] or no libkernlib.[so,a]"
+ USECERN="--disable-cern"
+ fi
+ fi
+ einfo
+ if [ "x$PYTHIA" = "x" ]
+ then
+ einfo "No support for pythia."
+ einfo "To install root with pythia support, use:"
+ einfo " export PYTHIA=<directory>/lib"
+ einfo "where <directory>/lib contains libPythia.[so,a]"
+ USEPYTHIA="--disable-pythia"
+ else
+ if [ -e $PYTHIA/libPythia.[so,a] ]
+ then
+ einfo "Support for pythia found."
+ USEPYTHIA="--enable-pythia --with-pythia-libdir=$PYTHIA"
+ else
+ einfo "No support for pythia."
+ einfo "PYTHIA = $PYTHIA has no libPythia.[so,a]"
+ USEPYTHIA="--disable-pythia"
+ fi
+ fi
+ einfo
+ if [ "x$PYTHIA6" = "x" ]
+ then
+ einfo "No support for pythia6."
+ einfo "To install root with pythia6 support, use:"
+ einfo " export PYTHIA6=<directory>/lib"
+ einfo "where <directory>/lib contains libPythia6.[so,a]"
+ USEPYTHIA6="--disable-pythia6"
+ else
+ if [ -e $PYTHIA6/libPythia6.[so,a] ]
+ then
+ einfo "Support for pythia6 found."
+ USEPYTHIA6="--enable-pythia6 --with-pythia6-libdir=$PYTHIA6"
+ else
+ einfo "No support for pythia6."
+ einfo "PYTHIA6 = $PYTHIA6 has no libPythia6.[so,a]"
+ USEPYTHIA6="--disable-pythia6"
+ fi
+ fi
+ einfo
+ if [ "x$VENUS" = "x" ]
+ then
+ einfo "No support for venus."
+ einfo "To install root with venus support, use:"
+ einfo " export VENUS=<directory>/lib"
+ einfo "where <directory>/lib contains libVenus.[so,a]"
+ USEVENUS="--disable-venus"
+ else
+ if [ -e $VENUS/libVenus.[so,a] ]
+ then
+ einfo "Support for venus found."
+ USEVENUS="--enable-venus --with-venus-libdir=$VENUS"
+ else
+ einfo "No support for venus."
+ einfo "VENUS = $VENUS has no libVenus.[so,a]"
+ USEVENUS="--disable-venus"
+ fi
+ fi
+
+ case $SYSTEM_ARCH in
+ ppc)
+ append-flags "-fsigned-char";;
+ esac
+
+ ./configure linux \
+ --aclocaldir=/usr/share/aclocal/ \
+ --bindir=/usr/bin \
+ --cintincdir=/usr/share/root/cint \
+ --datadir=/usr/share/root \
+ --docdir=/usr/share/doc/${P} \
+ --elispdir=/usr/share/emacs/site-lisp \
+ --etcdir=/etc/root \
+ --fontdir=/usr/share/root/fonts \
+ --iconpath=/usr/share/root/icons \
+ --incdir=/usr/include/root \
+ --libdir=/usr/lib/root \
+ --macrodir=/usr/share/root/macros \
+ --mandir=/usr/share/man/man1 \
+ --prefix=/usr \
+ --proofdir=/usr/share/root/proof \
+ --srcdir=/usr/share/root/src \
+ --testdir=/usr/share/doc/${P}/test \
+ --tutdir=/usr/share/doc/${P}/tutorial \
+ `use_enable afs` \
+ --disable-alien \
+ --disable-asimage \
+ $USECERN \
+ --disable-chirp \
+ --disable-dcache \
+ --disable-exceptions \
+ --disable-explicitlink \
+ --disable-globus \
+ `use_enable kerberos krb5` \
+ `use_enable ldap` \
+ `use_enable mysql` \
+ `use_enable opengl` \
+ --disable-openiv \
+ `use_enable postgres pgsql` \
+ $USEPYTHIA \
+ $USEPYTHIA6 \
+ `use_enable qt` \
+ --disable-rfio \
+ --disable-rpath \
+ --disable-sapdb \
+ --enable-shadowpw \
+ --enable-shared \
+ --enable-soversion \
+ --disable-srp \
+ --disable-table \
+ --enable-thread \
+ $USEVENUS \
+ ${myconf} || die "configure failed"
+ emake OPT="$CFLAGS" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} INSTALL="install" install || die "install failed"
+}