summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-11-18 12:29:04 +0000
committerThomas Sachau <tommy@gentoo.org>2010-11-18 12:29:04 +0000
commit20189caa88873c59c99678da8e4b3d0281c56cfe (patch)
tree131e1b05f1e1c216b6dc719656d66d302322cdc3 /dev-libs
parentRemoved not needed darwin patch, because apllied upstream (diff)
downloadhistorical-20189caa88873c59c99678da8e4b3d0281c56cfe.tar.gz
historical-20189caa88873c59c99678da8e4b3d0281c56cfe.tar.bz2
historical-20189caa88873c59c99678da8e4b3d0281c56cfe.zip
Initial commit, based on ebuild in enlightenment overlay
Package-Manager: portage-2.2.0_alpha2-r1/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/eina/ChangeLog10
-rw-r--r--dev-libs/eina/Manifest16
-rw-r--r--dev-libs/eina/eina-1.0.0_beta2.ebuild63
-rw-r--r--dev-libs/eina/metadata.xml64
4 files changed, 153 insertions, 0 deletions
diff --git a/dev-libs/eina/ChangeLog b/dev-libs/eina/ChangeLog
new file mode 100644
index 000000000000..53c1f4fe8d26
--- /dev/null
+++ b/dev-libs/eina/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/eina
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/ChangeLog,v 1.1 2010/11/18 12:29:04 tommy Exp $
+
+*eina-1.0.0_beta2 (18 Nov 2010)
+
+ 18 Nov 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +eina-1.0.0_beta2.ebuild, +metadata.xml:
+ Initial commit, based on ebuild in enlightenment overlay
+
diff --git a/dev-libs/eina/Manifest b/dev-libs/eina/Manifest
new file mode 100644
index 000000000000..11b490128940
--- /dev/null
+++ b/dev-libs/eina/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST eina-1.0.0.beta2.tar.bz2 534338 RMD160 c4a29e9b621ccef55b2c690f3dbc38fd7d80516d SHA1 f5c7fc6bd027a6865e7247489f126c54cc556d37 SHA256 69d77202cd867a13ff93eac907e068513feeb429e441700c6d592b2342fadeef
+EBUILD eina-1.0.0_beta2.ebuild 1765 RMD160 44a4ac1aedc1ea4a269259d2dfa5f6a5a21f2ce4 SHA1 223b87ab38c590a76fed493ec9110ad3a858d00d SHA256 a0430941d8bfe251bdb599b57c1caea146de71e93b35cb0877fd520541fe0afc
+MISC ChangeLog 393 RMD160 5e241ea07e289d40bf03e5b34977fa187cfa3c29 SHA1 c89287eb0fac243063377630bbda5aeac8f5f145 SHA256 f790743e1b9a9e0dcc768662a18d6ff5365ac045d39971a5a2dd4cc776ec2afa
+MISC metadata.xml 2145 RMD160 e4b0b7bc6904b4835d548e785cb1d8fe9ca813df SHA1 11a9167170debae9c2be17e088139a7a41962f87 SHA256 78cf232ee2e09f7185f8f06b37585e7222ebfcc9e9050560ecbca7f07d5a5df7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iJwEAQECAAYFAkzlHI8ACgkQG7kqcTWJkGfohgP/YS1pMOS7Vlxtm7I9Myc3TnLZ
+33/T86tmzbE7pjM4pXKdCMGpxFflUQ70Hz5CZT+fgoOsXRmnQfzFoJO0fes4QA4W
+g32Lkd6xohguP9rZAQUPNeSeYNaur+LEred0pL/qXJ7ujAF4SrHbK3tuw26o49c1
+hqmNdrI2jBGd8m3C3jw=
+=buPe
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/eina/eina-1.0.0_beta2.ebuild b/dev-libs/eina/eina-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..6300375bf627
--- /dev/null
+++ b/dev-libs/eina/eina-1.0.0_beta2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eina/eina-1.0.0_beta2.ebuild,v 1.1 2010/11/18 12:29:04 tommy Exp $
+
+EAPI="2"
+
+MY_P=${P/_beta/.beta}
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's data types library (List, hash, etc) in C"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="altivec debug default-mempool mempool-buddy +mempool-chained
+ mempool-fixed-bitmap +mempool-pass-through
+ mmx sse sse2 static-libs +threads"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? (
+ dev-libs/check
+ dev-libs/glib
+ dev-util/lcov
+ )"
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local MODULE_ARGUMENT="static"
+ if use debug ; then
+ MODULE_ARGUMENT="yes"
+ fi
+
+ # Evas benchmark is broken!
+ MY_ECONF="
+ $(use_enable altivec cpu-altivec)
+ $(use_enable !debug amalgamation)
+ $(use_enable debug stringshare-usage)
+ $(use_enable debug assert)
+ $(use debug || echo " --with-internal-maximum-log-level=2")
+ $(use_enable default-mempool)
+ $(use_enable doc)
+ $(use_enable mempool-buddy mempool-buddy $MODULE_ARGUMENT)
+ $(use_enable mempool-chained mempool-chained-pool $MODULE_ARGUMENT)
+ $(use_enable mempool-fixed-bitmap mempool-fixed-bitmap $MODULE_ARGUMENT)
+ $(use_enable mempool-pass-through mempool-pass-through $MODULE_ARGUMENT)
+ $(use_enable mmx cpu-mmx)
+ $(use_enable sse cpu-sse)
+ $(use_enable sse2 cpu-sse2)
+ $(use_enable threads posix-threads)
+ $(use test && echo " --disable-amalgamation")
+ $(use_enable test tests)
+ $(use_enable test coverage)
+ $(use_enable test benchmark)
+ --enable-magic-debug
+ --enable-safety-checks
+ "
+# $(use_enable test e17)
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eina/metadata.xml b/dev-libs/eina/metadata.xml
new file mode 100644
index 000000000000..a6cd7a8da38e
--- /dev/null
+++ b/dev-libs/eina/metadata.xml
@@ -0,0 +1,64 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name="mempool-chained">Compile "chained-pool" memory pool allocation.</flag>
+ <flag name="mempool-fixed-bitmap">Compile "fixed-bitmap" memory pool allocation.</flag>
+ <flag name="mempool-pass-through">Compile "pass-through" (system's malloc) memory pool allocation.</flag>
+ <flag name="mempool-buddy">Compile "buddy" memory pool allocation.</flag>
+ <flag name="default-mempool">By default use system's allocator (pass-through) instead of custom choice for Eina's own data structures.</flag>
+</use>
+<longdescription>
+Eina is a multi-platform library that provides optimized data types
+and useful tools for projects.
+
+Among its data types, Eina provides efficient implementation of:
+
+ * double linked list with O(1) append and count;
+
+ * double linked inlist (node is built in the data) with O(1) append;
+
+ * stringshare, a pool of read-only strings that are shared in order
+ to save memory (no copies!), fast referencing and
+ pointer-comparison;
+
+ * hash table with extensible key support, ships by default with
+ string, stringshare, pointer and integer hashes by default;
+
+ * array of pointers, with O(1) count and append, configurable step
+ growing;
+
+ * red-black tree;
+
+ * sparse matrix;
+
+
+As for tools, it provides couple of convenience:
+
+ * generic and extensible logging system;
+
+ * easy to use dynamic module loading (on top of dlopen()) that makes
+ it easy to change to static/built-in modules;
+
+ * generic safety-checks system covering NULL pointers and other
+ incorrect conditions with logging;
+
+ * "magic" type checking that check and logs if expected magic number
+ is incorrect;
+
+ * easy to use and extensible memory allocators (mempools);
+
+ * fixed-point arithmetic;
+
+ * tile splitter and simplifier (merges);
+
+ * generic iterator pattern (how to walk in one direction), just
+ implement the given API;
+
+ * generic accessor pattern (how to randomly access items), just
+ implement the given API;
+
+ * benchmark helpers.
+</longdescription>
+</pkgmetadata>