summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 17:03:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 17:03:16 +0000
commitf86af258ad344286039eb8cddc85faf32b613dfe (patch)
tree32919e766cba1f4004596e29ff13110491aaccc7 /dev-lisp/cl-arnesi
parentversion bump (diff)
downloadhistorical-f86af258ad344286039eb8cddc85faf32b613dfe.tar.gz
historical-f86af258ad344286039eb8cddc85faf32b613dfe.tar.bz2
historical-f86af258ad344286039eb8cddc85faf32b613dfe.zip
add inherit eutils
Diffstat (limited to 'dev-lisp/cl-arnesi')
-rw-r--r--dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild18
-rw-r--r--dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild11
2 files changed, 17 insertions, 12 deletions
diff --git a/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild b/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild
index 2e58a1f1d93e..aa8a1511a1a3 100644
--- a/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild
+++ b/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild
@@ -1,24 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild,v 1.1 2003/11/30 12:14:22 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-arnesi/cl-arnesi-1.1.0.ebuild,v 1.2 2004/04/21 16:51:00 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="arnesi is a collection of small bits and pieces of common lisp code."
HOMEPAGE="http://www.common-lisp.net/project/bese/#arnesi"
SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/arnesi_${PV}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
-# IUSE="doc"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
# doc? ( app-text/tetex )"
-CLPACKAGE=arnesi
-
S=${WORKDIR}/arnesi_${PV}
+CLPACKAGE=arnesi
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-sbcl-toplevel-gentoo.patch
@@ -44,9 +46,9 @@ src_install() {
}
pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE}
}
pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE}
}
diff --git a/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild b/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild
index 34910921921e..fbda93fa8275 100644
--- a/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild
+++ b/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild,v 1.2 2004/02/15 03:46:21 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-arnesi/cl-arnesi-1.1.1.ebuild,v 1.3 2004/04/21 16:51:17 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DESCRIPTION="arnesi is a collection of small bits and pieces of common lisp code."
HOMEPAGE="http://www.common-lisp.net/project/bese/#arnesi"
SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/arnesi/arnesi_${PV}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
-CLPACKAGE=arnesi
-
S=${WORKDIR}/arnesi_${PV}
+CLPACKAGE=arnesi
+
src_unpack() {
unpack ${A}
cd ${S}