summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-01 17:53:47 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-01 17:53:47 +0000
commit86eb257cc1bd15685c1c20bba40b6819b0881d79 (patch)
tree385cdb2c5f1f2a7e546d17721a26417592adc72d /dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
parentVersion bump. (diff)
downloadhistorical-86eb257cc1bd15685c1c20bba40b6819b0881d79.tar.gz
historical-86eb257cc1bd15685c1c20bba40b6819b0881d79.tar.bz2
historical-86eb257cc1bd15685c1c20bba40b6819b0881d79.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild')
-rw-r--r--dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
new file mode 100644
index 000000000000..345560b5446a
--- /dev/null
+++ b/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx-sbcl/cl-clx-sbcl-0.5.4.ebuild,v 1.1 2004/02/01 17:53:47 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CLX for SBCL"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/
+ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/sbcl"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_unpack() {
+ unpack ${A}
+ # this patch prevents building on clisp or cmucl
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+ find ${S} -type d -name CVS -exec rm -rf \;
+}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins ${S}/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}