summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-11-23 18:27:00 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-11-23 18:27:00 +0000
commit029369a2fb462dcf1188a56d99bf50c88d71e029 (patch)
tree514fc42061fb3c7f510b870edc4571a5c899689d /dev-lisp/cl-dot/cl-dot-0.1.ebuild
parentNew upstream version. (diff)
downloadhistorical-029369a2fb462dcf1188a56d99bf50c88d71e029.tar.gz
historical-029369a2fb462dcf1188a56d99bf50c88d71e029.tar.bz2
historical-029369a2fb462dcf1188a56d99bf50c88d71e029.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-lisp/cl-dot/cl-dot-0.1.ebuild')
-rw-r--r--dev-lisp/cl-dot/cl-dot-0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-dot/cl-dot-0.1.ebuild b/dev-lisp/cl-dot/cl-dot-0.1.ebuild
new file mode 100644
index 000000000000..131f53687638
--- /dev/null
+++ b/dev-lisp/cl-dot/cl-dot-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-dot/cl-dot-0.1.ebuild,v 1.1 2005/11/23 18:27:00 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp library for generating output for the Graphviz dot program"
+HOMEPAGE="http://www.cliki.net/cl-dot"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="media-gfx/graphviz"
+
+CLPACKAGE=cl-dot
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc README COPYING
+ insinto $CLSOURCEROOT/$CLPACKAGE/examples
+ doins examples/*.lisp
+}