summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-15 10:33:49 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-15 10:33:49 +0000
commit117db5eed7c32d564d4d50b196c2b511bb69d032 (patch)
tree9b6aea604f30679a78100cee4a929d0c6b423be9 /dev-lisp/cl-linedit
parent(no commit message) (diff)
downloadhistorical-117db5eed7c32d564d4d50b196c2b511bb69d032.tar.gz
historical-117db5eed7c32d564d4d50b196c2b511bb69d032.tar.bz2
historical-117db5eed7c32d564d4d50b196c2b511bb69d032.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-linedit')
-rw-r--r--dev-lisp/cl-linedit/ChangeLog10
-rw-r--r--dev-lisp/cl-linedit/Manifest6
-rw-r--r--dev-lisp/cl-linedit/cl-linedit-0.14.8.ebuild39
-rw-r--r--dev-lisp/cl-linedit/files/0.14.8-Makefile14
-rw-r--r--dev-lisp/cl-linedit/files/0.14.8-linedit.asd-uffi-glue-gentoo.patch69
-rw-r--r--dev-lisp/cl-linedit/files/digest-cl-linedit-0.14.81
-rw-r--r--dev-lisp/cl-linedit/metadata.xml26
7 files changed, 165 insertions, 0 deletions
diff --git a/dev-lisp/cl-linedit/ChangeLog b/dev-lisp/cl-linedit/ChangeLog
new file mode 100644
index 000000000000..4ac8d4857528
--- /dev/null
+++ b/dev-lisp/cl-linedit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-linedit
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-linedit/ChangeLog,v 1.1 2004/02/15 10:33:49 mkennedy Exp $
+
+*cl-linedit-0.14.8 (15 Feb 2004)
+
+ 15 Feb 2004; <mkennedy@gentoo.org> cl-linedit-0.14.8.ebuild, metadata.xml,
+ files/0.14.8-Makefile, files/0.14.8-linedit.asd-uffi-glue-gentoo.patch:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-linedit/Manifest b/dev-lisp/cl-linedit/Manifest
new file mode 100644
index 000000000000..57875b7b9445
--- /dev/null
+++ b/dev-lisp/cl-linedit/Manifest
@@ -0,0 +1,6 @@
+MD5 48a0b30a1a2286bcb46c13deb5750bf7 cl-linedit-0.14.8.ebuild 1037
+MD5 c12dc434890a31a073ff82279295a818 ChangeLog 391
+MD5 6310c8b01587b6100d7a50443ee27454 metadata.xml 820
+MD5 5f8cc94766061989efdc39a3138e88e6 files/0.14.8-linedit.asd-uffi-glue-gentoo.patch 2770
+MD5 8484e646d6628ae40d929863632d4e8e files/0.14.8-Makefile 164
+MD5 185f37d78a060f449f048c6571695583 files/digest-cl-linedit-0.14.8 65
diff --git a/dev-lisp/cl-linedit/cl-linedit-0.14.8.ebuild b/dev-lisp/cl-linedit/cl-linedit-0.14.8.ebuild
new file mode 100644
index 000000000000..ecc626928f0a
--- /dev/null
+++ b/dev-lisp/cl-linedit/cl-linedit-0.14.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-linedit/cl-linedit-0.14.8.ebuild,v 1.1 2004/02/15 10:33:49 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Linedit is a readline-style library written in Common Lisp that provides customizable line-editing features."
+HOMEPAGE=""
+SRC_URI="http://common-lisp.net/project/linedit/files/linedit_${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-terminfo
+ dev-lisp/cl-uffi"
+
+CLPACKAGE=linedit
+
+S=${WORKDIR}/linedit_${PV}
+
+src_unpack() {
+ unpack ${A}
+ # adds uffi-loader.lisp, removes building .so files
+ epatch ${FILESDIR}/${PV}-linedit.asd-uffi-glue-gentoo.patch
+ cp ${FILESDIR}/${PV}-Makefile ${S}/Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ common-lisp-install *.lisp linedit.asd version.lisp-expr
+ common-lisp-system-symlink
+ dodoc LICENSE
+ exeinto /usr/lib/linedit
+ doexe *.so
+}
diff --git a/dev-lisp/cl-linedit/files/0.14.8-Makefile b/dev-lisp/cl-linedit/files/0.14.8-Makefile
new file mode 100644
index 000000000000..0de155fbd03a
--- /dev/null
+++ b/dev-lisp/cl-linedit/files/0.14.8-Makefile
@@ -0,0 +1,14 @@
+
+CFLAGS=-fPIC -shared
+
+UFFI_LIBS=signals.so terminal_glue.so
+
+all: $(UFFI_LIBS)
+
+%.so : %.c
+ $(CC) $(CFLAGS) -o $@ $^
+
+clean:
+ rm -f $(UFFI_LIBS)
+
+.PHONY: clean
diff --git a/dev-lisp/cl-linedit/files/0.14.8-linedit.asd-uffi-glue-gentoo.patch b/dev-lisp/cl-linedit/files/0.14.8-linedit.asd-uffi-glue-gentoo.patch
new file mode 100644
index 000000000000..2a9d2c70b290
--- /dev/null
+++ b/dev-lisp/cl-linedit/files/0.14.8-linedit.asd-uffi-glue-gentoo.patch
@@ -0,0 +1,69 @@
+diff -urN linedit_0.14.8.original/linedit.asd linedit_0.14.8/linedit.asd
+--- linedit_0.14.8.original/linedit.asd 2003-11-06 08:18:19.000000000 -0600
++++ linedit_0.14.8/linedit.asd 2004-02-15 03:42:33.710137680 -0600
+@@ -23,30 +23,6 @@
+
+ (in-package :asdf)
+
+-(defvar *gcc* "/usr/bin/gcc")
+-
+-(defvar *gcc-options* '(#-darwin "-shared"
+- #+darwin "-bundle"
+- "-fPIC"))
+-
+-(defmethod output-files ((o compile-op) (c c-source-file))
+- (list (make-pathname :name (component-name c)
+- :type "so"
+- :defaults (component-pathname c))))
+-
+-(defmethod perform ((o load-op) (c c-source-file))
+- (let ((loader (intern "LOAD-FOREIGN-LIBRARY" :uffi)))
+- (dolist (f (input-files o c))
+- (funcall loader f))))
+-
+-(defmethod perform ((o compile-op) (c c-source-file))
+- (unless (zerop (run-shell-command "~A ~A ~{~A ~}-o ~A"
+- *gcc*
+- (namestring (component-pathname c))
+- *gcc-options*
+- (namestring (car (output-files o c)))))
+- (error 'operation-error :component c :operation o)))
+-
+ (defsystem :linedit
+ :version "0.14.4"
+ :depends-on (:uffi :terminfo)
+@@ -57,10 +33,10 @@
+ (:file "utility-functions" :depends-on ("packages"))
+
+ ;; Backend
+- (:file "backend" :depends-on ("utility-macros"))
+- (:c-source-file "terminal_glue")
++ (:file "uffi-loader" :depends-on ("packages"))
++ (:file "backend" :depends-on ("utility-macros" "uffi-loader"))
+ (:file "terminal-translations" :depends-on ("packages"))
+- (:file "terminal" :depends-on ("terminal-translations" "backend" "terminal_glue"))
++ (:file "terminal" :depends-on ("terminal-translations" "backend"))
+ (:file "smart-terminal" :depends-on ("terminal"))
+ (:file "dumb-terminal" :depends-on ("terminal"))
+
+@@ -69,8 +45,7 @@
+ (:file "line" :depends-on ("utility-macros"))
+ (:file "buffer" :depends-on ("utility-macros"))
+ (:file "command-keys" :depends-on ("packages"))
+- (:c-source-file "signals")
+- (:file "editor" :depends-on ("backend" "rewindable" "signals"
++ (:file "editor" :depends-on ("backend" "rewindable"
+ "line" "buffer" "command-keys"))
+ (:file "main" :depends-on ("editor"))
+ (:file "complete" :depends-on ("utility-macros"))
+diff -urN linedit_0.14.8.original/uffi-loader.lisp linedit_0.14.8/uffi-loader.lisp
+--- linedit_0.14.8.original/uffi-loader.lisp 1969-12-31 18:00:00.000000000 -0600
++++ linedit_0.14.8/uffi-loader.lisp 2004-02-15 03:46:59.595716928 -0600
+@@ -0,0 +1,7 @@
++;;;; -*- mode: lisp; syntax: common-lisp; indent-tabs-mode: nil; base: 10; package: linedit -*-
++
++(in-package :linedit)
++
++(uffi:load-foreign-library #p"/usr/lib/linedit/signals.so")
++(uffi:load-foreign-library #p"/usr/lib/linedit/terminal_glue.so")
++
diff --git a/dev-lisp/cl-linedit/files/digest-cl-linedit-0.14.8 b/dev-lisp/cl-linedit/files/digest-cl-linedit-0.14.8
new file mode 100644
index 000000000000..ee69560b6943
--- /dev/null
+++ b/dev-lisp/cl-linedit/files/digest-cl-linedit-0.14.8
@@ -0,0 +1 @@
+MD5 9daf012d10e0a0f781981a4bc6adb4bd linedit_0.14.8.tar.gz 12476
diff --git a/dev-lisp/cl-linedit/metadata.xml b/dev-lisp/cl-linedit/metadata.xml
new file mode 100644
index 000000000000..2376935ae6b1
--- /dev/null
+++ b/dev-lisp/cl-linedit/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Linedit is a readline-style library written in Common Lisp that
+provides customizable line-editing features, licensed under a
+MIT-style license.
+
+Linedit uses UFFI for foreign bindings, so it is a least theoretically
+portable, though REPL-wrapping is currently SBCL specific. Features
+
+ * single-line text reader
+ * multi-line form reader
+ * completions on packages and symbols in current image
+ * completions on directories and filenames
+ * apropos-word and describe-word
+ * unlimited undo
+ * unlimited kill-ring
+ * unlimited history
+ * multiple histories
+ * use in REPL on SBCL
+ * paging
+ * fully customizable in CL
+</longdescription>
+</pkgmetadata>