summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit5ac964845b215505f8e7dca14719e32ce27b6cf5 (patch)
tree3d3e3a2ef62c1f538eec3c7d9fca33ad0180e87c /dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
parentBump to 0.5 (diff)
downloadhistorical-5ac964845b215505f8e7dca14719e32ce27b6cf5.tar.gz
historical-5ac964845b215505f8e7dca14719e32ce27b6cf5.tar.bz2
historical-5ac964845b215505f8e7dca14719e32ce27b6cf5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild')
-rw-r--r--dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
new file mode 100644
index 000000000000..81645ff9520f
--- /dev/null
+++ b/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-bool-comp/cl-rsm-bool-comp-1.0-r1.ebuild,v 1.1 2004/02/12 09:13:19 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="R. Scott McIntire's Common Lisp Boolean Function Comparison library."
+HOMEPAGE="http://packages.debian.org/unstable/devel/cl-rsm-bool-comp.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-rsm-bool-comp/cl-rsm-bool-comp_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+# Compilation problems on SBCL and runtime SEGV on CMUCL
+KEYWORDS="-*"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp "
+
+CLPACKAGE=rsm-bool-comp
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch.gz
+}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc copying copyright
+ dohtml *.html *.jpg
+ do-debian-credits
+}