summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-10 17:39:35 +0000
commit6ee348b8417871f03f4f2c0abb8e4990edf88ec4 (patch)
tree380cd67b4c0832fa8bd93e42f40984333c97d6c0 /dev-lisp/clisp/clisp-2.28.ebuild
parentdont access $CC (diff)
downloadhistorical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.tar.gz
historical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.tar.bz2
historical-6ee348b8417871f03f4f2c0abb8e4990edf88ec4.zip
if anyone reads these diffs, these were good examples of things you should never do in your ebuild
Diffstat (limited to 'dev-lisp/clisp/clisp-2.28.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.28.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/dev-lisp/clisp/clisp-2.28.ebuild b/dev-lisp/clisp/clisp-2.28.ebuild
index 0bf05fdd2313..c2babebc5d39 100644
--- a/dev-lisp/clisp/clisp-2.28.ebuild
+++ b/dev-lisp/clisp/clisp-2.28.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.6 2004/03/30 20:58:13 spyderous Exp $
-
-IUSE="X"
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.28.ebuild,v 1.7 2004/05/10 17:39:35 vapier Exp $
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="http://cvs2.cons.org/ftp-area/clisp/source/latest/${P}.tar.gz"
-S=${WORKDIR}/${P}
-DEPEND="X? ( virtual/x11 )"
-RDEPEND="$DEPEND"
+
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="x86"
+IUSE="X"
+
+DEPEND="X? ( virtual/x11 )"
src_compile() {
local myconf="--with-dynamic-ffi --with-dynamic-modules --with-export-syscalls --with-module=wildcard --with-module=regexp --with-module=bindings/linuxlibc6"
- if [ -n "`use X`" ] ; then
- myconf="${myconf} --with-module=clx/new-clx"
- fi
+ use X && myconf="${myconf} --with-module=clx/new-clx"
unset CHOST # compilation of modules fails if we don't do this
unset CFLAGS
@@ -33,11 +30,9 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
cd src
make DESTDIR=${D} prefix=/usr install-bin || die
- install -Dm 644 clisp.1 ${D}/usr/share/man/man1/clisp.1
- install -Dm 644 clreadline.3 ${D}/usr/share/man/man3/clreadline.3
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
+ doman clisp.1 clreadline.3
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html clreadline.dvi clreadline.html
}
-