summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-22 22:01:55 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-22 22:01:55 +0000
commitc17ccb1a93e65621fdd1b8998c448715cc71c082 (patch)
tree94f8f51afb3599a7b8cc813104dbb9c36861c596 /dev-lisp/clisp/clisp-2.36.ebuild
parentVersion bump (bug #116410). (diff)
downloadhistorical-c17ccb1a93e65621fdd1b8998c448715cc71c082.tar.gz
historical-c17ccb1a93e65621fdd1b8998c448715cc71c082.tar.bz2
historical-c17ccb1a93e65621fdd1b8998c448715cc71c082.zip
Depend on >=dev-db/postgresql-8.0*; Install implementation notes and PDF documentation; Resolves Bug #105703 and #107515 respectively.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'dev-lisp/clisp/clisp-2.36.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.36.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lisp/clisp/clisp-2.36.ebuild b/dev-lisp/clisp/clisp-2.36.ebuild
index 71e82ea613bb..3e75280a4c43 100644
--- a/dev-lisp/clisp/clisp-2.36.ebuild
+++ b/dev-lisp/clisp/clisp-2.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.36.ebuild,v 1.2 2005/12/12 04:11:38 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.36.ebuild,v 1.3 2005/12/22 22:01:55 mkennedy Exp $
inherit flag-o-matic common-lisp-common-2 eutils toolchain-funcs
@@ -18,7 +18,7 @@ DEPEND="dev-libs/libsigsegv
sys-devel/gettext
virtual/tetex
fastcgi? ( dev-libs/fcgi )
- postgres? ( dev-db/postgresql )
+ postgres? ( >=dev-db/postgresql-8.0* )
X? ( virtual/x11 )
readline? ( sys-libs/readline )
pcre? ( dev-libs/libpcre )
@@ -70,6 +70,12 @@ src_install() {
doins ${FILESDIR}/${PV}/install-clc.lisp
dodoc ${FILESDIR}/${PV}/README.Gentoo
keepdir /usr/lib/common-lisp/clisp
+
+ dohtml doc/impnotes.{css,html}
+ dohtml build/clisp.html
+ dohtml doc/clisp.png
+ dodoc build/clisp.{ps,pdf}
+ dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
}
pkg_preinst() {