summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-03-24 21:52:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-03-24 21:52:12 +0000
commiteba2c0ae6b099a1af9eab4c2f40157a6efea0a0f (patch)
tree2052610fdcd074915c4d1b9e16f195839890a449 /dev-lisp/sbcl
parentVersion bumped. Marked previous version stable. (diff)
downloadhistorical-eba2c0ae6b099a1af9eab4c2f40157a6efea0a0f.tar.gz
historical-eba2c0ae6b099a1af9eab4c2f40157a6efea0a0f.tar.bz2
historical-eba2c0ae6b099a1af9eab4c2f40157a6efea0a0f.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/sbcl')
-rw-r--r--dev-lisp/sbcl/ChangeLog6
-rw-r--r--dev-lisp/sbcl/files/0.8.8/sbclrc18
-rw-r--r--dev-lisp/sbcl/sbcl-0.8.8.ebuild4
3 files changed, 25 insertions, 3 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index a289507b7a07..525654604cbd 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.29 2004/03/24 04:21:49 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.30 2004/03/24 21:52:12 mkennedy Exp $
+
+ 24 Mar 2004; <mkennedy@gentoo.org> sbcl-0.8.8.ebuild, files/0.8.8/sbclrc:
+ Corrected path to system-wide SBCL configuration (should be /etc/sbclrc, not
+ /etc/sbcl.rc)
23 Mar 2004; <mkennedy@gentoo.org> sbcl-0.8.8.ebuild:
Marking stable for x86
diff --git a/dev-lisp/sbcl/files/0.8.8/sbclrc b/dev-lisp/sbcl/files/0.8.8/sbclrc
new file mode 100644
index 000000000000..91f31720d896
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.8.8/sbclrc
@@ -0,0 +1,18 @@
+;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Package: CL-USER -*-
+
+;;; This file is installed as /etc/sbcl.rc and run on every invocation
+;;; of SBCL
+
+(if (probe-file "/etc/lisp-config.lisp")
+ (load "/etc/lisp-config.lisp")
+ (format t "~%;;; Warning: there is no /etc/lisp-config.lisp file"))
+
+;;; The following is required if you want source location functions to
+;;; work (such as those called when you use M-. (edit definition) in
+;;; ILISP or SLIME)
+
+(setf (logical-pathname-translations "SYS")
+ '(("SYS:SRC;**;*.*.*" #p"/usr/lib/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*" #p"/usr/lib/sbcl/**/*.*")))
+
+;;; sbclrc ends here
diff --git a/dev-lisp/sbcl/sbcl-0.8.8.ebuild b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
index 8c8b634ef07d..e4ff5e3a5ecf 100644
--- a/dev-lisp/sbcl/sbcl-0.8.8.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.3 2004/03/24 04:21:49 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.8.8.ebuild,v 1.4 2004/03/24 21:52:12 mkennedy Exp $
inherit common-lisp-common
@@ -77,7 +77,7 @@ src_install() {
unset SBCL_HOME
insinto /etc/
- doins ${FILESDIR}/${PV}/sbcl.rc # Gentoo specific (from Debian)
+ doins ${FILESDIR}/${PV}/sbclrc # Gentoo specific (from Debian)
exeinto /usr/lib/common-lisp/bin
doexe ${FILESDIR}/${PV}/sbcl.sh # Gentoo specific (from Debian)