summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-19 23:16:45 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-19 23:16:45 +0000
commit301a0b6c71e3232ae5857c4832c2cbb027acd55e (patch)
tree856f3f6aa5b852d45672843c6aeae43136fd4c7c /dev-lisp
parentRevision bump, 0.1.15 had 2 minor issues in the new dep-clean see ChangeLog (diff)
downloadhistorical-301a0b6c71e3232ae5857c4832c2cbb027acd55e.tar.gz
historical-301a0b6c71e3232ae5857c4832c2cbb027acd55e.tar.bz2
historical-301a0b6c71e3232ae5857c4832c2cbb027acd55e.zip
"Gauche OpenGL 1.1 bindings; initial import"
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche-gl/ChangeLog11
-rw-r--r--dev-lisp/gauche-gl/files/0.1.3/destdir-gentoo.diff45
-rw-r--r--dev-lisp/gauche-gl/files/0.1.3/nvidia-headers-gentoo.diff12
-rw-r--r--dev-lisp/gauche-gl/files/digest-gauche-gl-0.1.31
-rw-r--r--dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild49
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-lisp/gauche-gl/ChangeLog b/dev-lisp/gauche-gl/ChangeLog
new file mode 100644
index 000000000000..09f31d285bdc
--- /dev/null
+++ b/dev-lisp/gauche-gl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lisp/gauche-gl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/ChangeLog,v 1.1 2002/07/19 23:16:45 karltk Exp $
+
+*gauche-gl-0.1.3 (19 Jul 2002)
+
+ 19 Jul 2002; Karl Trygve Kalleberg <karltk@gentoo.org> gauche-gl-0.1.3.ebuild files/digest-gauche-gl-0.1.3 :
+
+ OpenGL 1.1 bindings for Gauche.
+
+ Initial import.
diff --git a/dev-lisp/gauche-gl/files/0.1.3/destdir-gentoo.diff b/dev-lisp/gauche-gl/files/0.1.3/destdir-gentoo.diff
new file mode 100644
index 000000000000..e9a274c48268
--- /dev/null
+++ b/dev-lisp/gauche-gl/files/0.1.3/destdir-gentoo.diff
@@ -0,0 +1,45 @@
+diff -urN --exclude '*.c' --exclude 'config.*' --exclude '*.stub' --exclude Makefile Gauche-gl/Makefile.in Gauche-gl.tainted/Makefile.in
+--- Gauche-gl.vanilla/Makefile.in Fri Feb 15 11:11:11 2002
++++ Gauche-gl/Makefile.in Sat Jul 20 00:56:13 2002
+@@ -19,8 +19,8 @@
+ rm -rf $(CONFIG_GENERATED)
+
+ install :
+- cd src; $(MAKE) install
+- cd lib; $(MAKE) install
++ cd src; $(MAKE) DESTDIR=$(DESTDIR) install
++ cd lib; $(MAKE) DESTDIR=$(DESTDIR) install
+
+ realclean : clean
+ cd src; $(MAKE) realclean
+diff -urN --exclude '*.c' --exclude 'config.*' --exclude '*.stub' --exclude Makefile Gauche-gl/lib/Makefile.in Gauche-gl.tainted/lib/Makefile.in
+--- Gauche-gl.vanilla/lib/Makefile.in Wed Oct 10 11:42:57 2001
++++ Gauche-gl/lib/Makefile.in Sat Jul 20 00:56:37 2002
+@@ -3,7 +3,8 @@
+ GAUCHE_CONFIG = @GAUCHE_CONFIG@
+ INSTALL = @INSTALL@
+ INSTALL_TYPE = @INSTALL_TYPE@
+-SCM_INSTALL_DIR = `$(GAUCHE_CONFIG) --$(INSTALL_TYPE)libdir`
++DESTDIR =
++SCM_INSTALL_DIR = $(DESTDIR)/`$(GAUCHE_CONFIG) --$(INSTALL_TYPE)libdir`
+
+ SCMFILES = gl.scm \
+ gl/glut.scm
+diff -urN --exclude '*.c' --exclude 'config.*' --exclude '*.stub' --exclude Makefile Gauche-gl/src/Makefile.in Gauche-gl.tainted/src/Makefile.in
+--- Gauche-gl.vanilla/src/Makefile.in Fri Jul 19 11:05:35 2002
++++ Gauche-gl/src/Makefile.in Sat Jul 20 00:54:54 2002
+@@ -20,10 +20,11 @@
+ gl_head.c gl_tail.c glut_head.c glut_tail.c
+ GENERATED = gl-lib.c glu-lib.c glut-lib.c gettype-sizes.c
+
++DESTDIR =
+ INSTALL_TYPE = @INSTALL_TYPE@
+-HEADER_INSTALL_DIR = `$(GAUCHE_CONFIG) --$(INSTALL_TYPE)incdir`
+-SCM_INSTALL_DIR = `$(GAUCHE_CONFIG) --$(INSTALL_TYPE)libdir`
+-ARCH_INSTALL_DIR = `$(GAUCHE_CONFIG) --$(INSTALL_TYPE)archdir`
++HEADER_INSTALL_DIR = $(DESTDIR)/`$(GAUCHE_CONFIG) --$(INSTALL_TYPE)incdir`
++SCM_INSTALL_DIR = $(DESTDIR)/`$(GAUCHE_CONFIG) --$(INSTALL_TYPE)libdir`
++ARCH_INSTALL_DIR = $(DESTDIR)/`$(GAUCHE_CONFIG) --$(INSTALL_TYPE)archdir`
+
+ all : $(TARGET)
+
diff --git a/dev-lisp/gauche-gl/files/0.1.3/nvidia-headers-gentoo.diff b/dev-lisp/gauche-gl/files/0.1.3/nvidia-headers-gentoo.diff
new file mode 100644
index 000000000000..77b92fe03ee4
--- /dev/null
+++ b/dev-lisp/gauche-gl/files/0.1.3/nvidia-headers-gentoo.diff
@@ -0,0 +1,12 @@
+diff -urN --exclude '*.c' --exclude 'config.*' --exclude Makefile.in --exclude Makefile Gauche-gl/src/gl-syms.stub Gauche-gl.tainted/src/gl-syms.stub
+--- Gauche-gl.vanilla/src/gl-syms.stub Fri Jul 19 05:12:48 2002
++++ Gauche-gl/src/gl-syms.stub Sat Jul 20 00:51:45 2002
+@@ -17,6 +17,8 @@
+
+ "
+ #include \"gauche-gl.h\"
++#undef GL_EXT_texture_object
++#include <GL/glext.h>
+ "
+
+ ;;=============================================================
diff --git a/dev-lisp/gauche-gl/files/digest-gauche-gl-0.1.3 b/dev-lisp/gauche-gl/files/digest-gauche-gl-0.1.3
new file mode 100644
index 000000000000..e61d9bafe7ce
--- /dev/null
+++ b/dev-lisp/gauche-gl/files/digest-gauche-gl-0.1.3
@@ -0,0 +1 @@
+MD5 a08cfd2f4902b7bc1eab595a785b1536 Gauche-gl-0.1.3.tgz 96122
diff --git a/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild b/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild
new file mode 100644
index 000000000000..5917f5719867
--- /dev/null
+++ b/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche-gl/gauche-gl-0.1.3.ebuild,v 1.1 2002/07/19 23:16:45 karltk Exp $
+
+DESCRIPTION="OpenGL 1.1 bindings for Gauche"
+HOMEPAGE="http://gauche.sf.net"
+SRC_URI="mirror://sourceforge/gauche/Gauche-gl-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0.1"
+KEYWORDS="x86"
+DEPEND="virtual/glibc
+ virtual/opengl
+ >=dev-lisp/gauche-0.6
+ >=media-libs/glut-3.7"
+RDEPEND="$DEPEND"
+S=${WORKDIR}/Gauche-gl
+
+src_unpack() {
+ unpack Gauche-gl-${PV}.tgz || die
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PV}/nvidia-headers-gentoo.diff || die
+ patch -p1 < ${FILESDIR}/${PV}/destdir-gentoo.diff || die
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ #emake || die
+ make || die
+}
+
+src_install () {
+ dodir `gauche-config --syslibdir`
+ dodir `gauche-config --sysarchdir`
+ dodir `gauche-config --sysincdir`
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING README ChangeLog INSTALL* VERSION
+ local expls=/usr/share/${P}/examples
+ dodir ${expls}/glbook
+ insinto ${expls}
+ doins examples/mandelbrot.scm
+ insinto ${expls}/glbook
+ doins examples/glbook/*
+}