summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 12:36:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 12:36:35 +0000
commit6e057d22da2e4ca05e46852c662baf7f32b7897f (patch)
tree6821078e730e810014fb9c0181dd21da93ccba59 /dev-ml/core
parentFix the mess caused by previous commit. SCTP _is_ in tree. (diff)
downloadhistorical-6e057d22da2e4ca05e46852c662baf7f32b7897f.tar.gz
historical-6e057d22da2e4ca05e46852c662baf7f32b7897f.tar.bz2
historical-6e057d22da2e4ca05e46852c662baf7f32b7897f.zip
initial import, ebuild by me
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog10
-rw-r--r--dev-ml/core/Manifest14
-rw-r--r--dev-ml/core/core-0.6.0.ebuild47
-rw-r--r--dev-ml/core/metadata.xml14
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
new file mode 100644
index 000000000000..563147e11016
--- /dev/null
+++ b/dev-ml/core/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/core
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.1 2009/10/27 12:36:35 aballier Exp $
+
+*core-0.6.0 (27 Oct 2009)
+
+ 27 Oct 2009; Alexis Ballier <aballier@gentoo.org> +core-0.6.0.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/core/Manifest b/dev-ml/core/Manifest
new file mode 100644
index 000000000000..a1b9d1ac85bb
--- /dev/null
+++ b/dev-ml/core/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST core-0.6.0.tgz 361224 RMD160 7fe705aa2c92bbd2be51b82b271617fefa4ab526 SHA1 eb18d710414ed712599719bd90304e0b08daba8e SHA256 465448016b90f59921ad032dc24330f148de6d3a1e19323ad975b1ba76771004
+EBUILD core-0.6.0.ebuild 1102 RMD160 4976f3ae7003137abc062de73e060691d4e47f6a SHA1 50f28a2ccc866b5f4864dd13e9521839c5bdd9ea SHA256 6c0d88905e442f276b08040686ac69bd8c373e033f8bc480c5436e647673d118
+MISC ChangeLog 345 RMD160 9134c6b7cfe7928b9b9fb8453a3a31c02ab23197 SHA1 7165f64958bce463f81f47bcec66e3c003d9069b SHA256 11daaece015c18789fd35b983db210f72860ee40fce79b751605aead7f25003a
+MISC metadata.xml 544 RMD160 1e10e2f2b20afd5632d63194d0ab99167e975dc5 SHA1 81f571fd9974ac53e79ac08c5df20ea10edce61a SHA256 5779df3b70a633829dcb09a18f99a65ac4124e5fac46a16b523da4f445bdc715
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.13 (GNU/Linux)
+
+iEYEARECAAYFAkrm6VkACgkQvFcC4BYPU0pyTACgplS/kPIA6itC7fW67F9+y/N9
+jcQAoMah9plfxAKPObGOoeTCtYSiR8lb
+=wdyJ
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/core/core-0.6.0.ebuild b/dev-ml/core/core-0.6.0.ebuild
new file mode 100644
index 000000000000..7dede9f282df
--- /dev/null
+++ b/dev-ml/core/core-0.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.6.0.ebuild,v 1.1 2009/10/27 12:36:35 aballier Exp $
+
+EAPI="2"
+inherit findlib
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tgz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
+ dev-ml/res
+ dev-ml/sexplib
+ dev-ml/bin-prot
+ dev-ml/fieldslib
+ dev-ml/pcre-ocaml"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/ounit
+ dev-ml/type-conv
+ )"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ cd "${S}/extended_test"
+ ocamlfind ocamlc -package bigarray,oUnit,type-conv,sexplib,bin_prot,res,fieldslib,pcre,threads -thread -dtypes -I ../extended -I ../lib yes.ml -o yes.exe || die
+ for i in lib extended ; do
+ cd "${S}/${i}_test"
+ emake || die
+ ./test_runner.exe || die
+ done
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc README
+}
diff --git a/dev-ml/core/metadata.xml b/dev-ml/core/metadata.xml
new file mode 100644
index 000000000000..3a9dfe0e889c
--- /dev/null
+++ b/dev-ml/core/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <longdescription lang="en">
+ Core is Jane Street Capital's Ocaml standard library overlay. It
+ provides tail recursive versions of non tail recursive functions in
+ the standard library, changes the signature of many of the standard
+ modules, and adds new functionality.
+
+ Core_extended adds new functionality, but is only code reviewed on an
+ ad-hoc basis.
+ </longdescription>
+</pkgmetadata>