summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:22 +0000
commit18ba402e426ad5afc840dcb764010a603bf4e7b1 (patch)
treea6eca94f9602e802b1a0ed0152b315a8afd4cf52 /dev-ml
parentversion bump, by Vladimir Ivanov, bug #361165 (diff)
downloadhistorical-18ba402e426ad5afc840dcb764010a603bf4e7b1.tar.gz
historical-18ba402e426ad5afc840dcb764010a603bf4e7b1.tar.bz2
historical-18ba402e426ad5afc840dcb764010a603bf4e7b1.zip
version bump, by Vladimir Ivanov, bug #361161
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/sexplib/ChangeLog7
-rw-r--r--dev-ml/sexplib/sexplib-5.2.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index 8fcf2e98aeb4..09107ba7e3d1 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.6 2011/02/24 20:11:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.7 2011/06/25 18:56:22 aballier Exp $
+
+*sexplib-5.2.1 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org> +sexplib-5.2.1.ebuild:
+ version bump, by Vladimir Ivanov, bug #361161
*sexplib-5.2.0 (24 Feb 2011)
diff --git a/dev-ml/sexplib/sexplib-5.2.1.ebuild b/dev-ml/sexplib/sexplib-5.2.1.ebuild
new file mode 100644
index 000000000000..dfcc8b44a794
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-5.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-5.2.1.ebuild,v 1.1 2011/06/25 18:56:22 aballier Exp $
+
+EAPI=3
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/type-conv-2.3.0"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}