summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-01-31 18:36:52 +0000
committerTorsten Veller <tove@gentoo.org>2012-01-31 18:36:52 +0000
commit254b984a7f09e8457a1f06632f27efc3af894f60 (patch)
tree03a89f2ac9860f83e8c373fceb0bcf3391266308 /dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild
parentStable for HPPA (bug #400559). (diff)
downloadhistorical-254b984a7f09e8457a1f06632f27efc3af894f60.tar.gz
historical-254b984a7f09e8457a1f06632f27efc3af894f60.tar.bz2
historical-254b984a7f09e8457a1f06632f27efc3af894f60.zip
[bump] dev-perl/Apache-Test-1.370.0
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild
new file mode 100644
index 000000000000..6a81df48fb26
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.370.0.ebuild,v 1.1 2012/01/31 18:36:52 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.37
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}