summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-10-21 16:38:36 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-10-21 16:38:36 +0000
commit2db44dea35e0c87cf5edc4ad5eb6b42eb88aa104 (patch)
tree73fdf907431193c22cc1bd66374cfba91fe33b0e /dev-perl/Curses/Curses-1.15.ebuild
parentVersion bump, remove old version. Adds support for strigi, bug #149362 (diff)
downloadhistorical-2db44dea35e0c87cf5edc4ad5eb6b42eb88aa104.tar.gz
historical-2db44dea35e0c87cf5edc4ad5eb6b42eb88aa104.tar.bz2
historical-2db44dea35e0c87cf5edc4ad5eb6b42eb88aa104.zip
Version bump
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'dev-perl/Curses/Curses-1.15.ebuild')
-rw-r--r--dev-perl/Curses/Curses-1.15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Curses/Curses-1.15.ebuild b/dev-perl/Curses/Curses-1.15.ebuild
new file mode 100644
index 000000000000..3887c8471b22
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/Curses-1.15.ebuild,v 1.1 2006/10/21 16:27:11 mcummings Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Curses interface modules for Perl"
+HOMEPAGE="http://search.cpan.org/~giraffed/${P}/"
+SRC_URI="mirror://cpan/authors/id/G/GI/GIRAFFED/${P}.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5
+ dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+myconf="${myconf} GEN PANELS MENUS"
+
+#This patch may or may not be backwards compatible with perl-5.6.1
+#Add gaurd as necessary...
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/Curses-1.08-p5.8-fixes.diff
+ einfo "Copying hints/c-linux.ncurses.h to c-config.h"
+ cp hints/c-linux.ncurses.h c-config.h
+}