summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-07-29 20:42:39 +0000
committerTorsten Veller <tove@gentoo.org>2009-07-29 20:42:39 +0000
commit93b2137ad4dbb7d9c3268cea4dcb22fcffb633a9 (patch)
treec628c6561b858edb36cb0d65991b2696872b63ab /dev-perl/libwww-perl
parentThere's no such thing as cedaga in tree. (diff)
downloadhistorical-93b2137ad4dbb7d9c3268cea4dcb22fcffb633a9.tar.gz
historical-93b2137ad4dbb7d9c3268cea4dcb22fcffb633a9.tar.bz2
historical-93b2137ad4dbb7d9c3268cea4dcb22fcffb633a9.zip
Version bump
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.830.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index c4b934952cfd..4324f29cfbd6 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.108 2009/07/19 17:47:44 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.109 2009/07/29 20:42:39 tove Exp $
+
+*libwww-perl-5.830 (29 Jul 2009)
+
+ 29 Jul 2009; Torsten Veller <tove@gentoo.org> +libwww-perl-5.830.ebuild:
+ Version bump
19 Jul 2009; Torsten Veller <tove@gentoo.org> libwww-perl-5.805.ebuild,
libwww-perl-5.829.ebuild:
diff --git a/dev-perl/libwww-perl/libwww-perl-5.830.ebuild b/dev-perl/libwww-perl/libwww-perl-5.830.ebuild
new file mode 100644
index 000000000000..9765f47405fa
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.830.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.830.ebuild,v 1.1 2009/07/29 20:42:39 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-IO-Compress-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ perl-module_src_install
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+}