summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-30 07:20:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-30 07:20:41 +0000
commit4d298d71adedbf114a31a65a229d97c432c29db9 (patch)
treeb53e28a47aa2e1ab5208acde62f7e66760a7cc13 /dev-perl/mod_perl/mod_perl-1.27-r1.ebuild
parentMasking Speex cause someone has to (diff)
downloadhistorical-4d298d71adedbf114a31a65a229d97c432c29db9.tar.gz
historical-4d298d71adedbf114a31a65a229d97c432c29db9.tar.bz2
historical-4d298d71adedbf114a31a65a229d97c432c29db9.zip
revision bumps to force installations into correct locations after MakeMaker upgrade
Diffstat (limited to 'dev-perl/mod_perl/mod_perl-1.27-r1.ebuild')
-rw-r--r--dev-perl/mod_perl/mod_perl-1.27-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/mod_perl/mod_perl-1.27-r1.ebuild b/dev-perl/mod_perl/mod_perl-1.27-r1.ebuild
new file mode 100644
index 000000000000..2e64cb92feaf
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.27-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.27-r1.ebuild,v 1.1 2002/10/30 07:20:41 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Perl Module for Apache"
+SRC_URI="http://perl.apache.org/dist/${P}.tar.gz"
+HOMEPAGE="http://perl.apache.org"
+
+SLOT="0"
+LICENSE="Apache-1.1 as-is"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="sys-devel/perl
+ dev-perl/libwww-perl
+ >=net-www/apache-1.3.24-r1"
+
+src_compile() {
+ perl Makefile.PL USE_APXS=1 \
+ PREFIX=${D}/usr \
+ WITH_APXS=/usr/sbin/apxs EVERYTHING=1
+
+ cp Makefile Makefile.orig
+ sed -e "s:apxs_install doc_install:doc_install:" Makefile.orig > Makefile
+ emake || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
+
+ dodoc Changes CREDITS MANIFEST README SUPPORT ToDo
+ dohtml -r ./
+
+ cd apaci
+ exeinto /usr/lib/apache-extramodules
+ doexe libperl.so
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libperl.so mod_perl.c perl_module \
+ define=PERL
+
+ :;
+}