summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-04-16 13:11:41 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-04-16 13:11:41 +0000
commitf58292aaf90a63ddeefc4d9ebbf24b67be594bda (patch)
treece5d2b135837dbec164784c02c0f0e76f84bd40e /dev-perl/module-build/module-build-0.28.07.ebuild
parentStable on sparc wrt security #174043 (diff)
downloadhistorical-f58292aaf90a63ddeefc4d9ebbf24b67be594bda.tar.gz
historical-f58292aaf90a63ddeefc4d9ebbf24b67be594bda.tar.bz2
historical-f58292aaf90a63ddeefc4d9ebbf24b67be594bda.zip
Version bump
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'dev-perl/module-build/module-build-0.28.07.ebuild')
-rw-r--r--dev-perl/module-build/module-build-0.28.07.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/module-build/module-build-0.28.07.ebuild b/dev-perl/module-build/module-build-0.28.07.ebuild
new file mode 100644
index 000000000000..c884e135b7ce
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.07.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.07.ebuild,v 1.1 2007/04/16 13:11:41 mcummings Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ test? ( <dev-perl/version-0.72.01 )
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"