summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-01-23 15:32:24 +0000
committerTorsten Veller <tove@gentoo.org>2011-01-23 15:32:24 +0000
commitc98f7b57b35bc86b2288002c91393eef4a1b1877 (patch)
treed78804af305b5d0e72c0ecee5ae6e6c41d570f3e /dev-perl
parentVersion bump. Cleanup (diff)
downloadhistorical-c98f7b57b35bc86b2288002c91393eef4a1b1877.tar.gz
historical-c98f7b57b35bc86b2288002c91393eef4a1b1877.tar.bz2
historical-c98f7b57b35bc86b2288002c91393eef4a1b1877.zip
Version bump
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.350.ebuild35
-rw-r--r--dev-perl/Apache-Test/ChangeLog7
-rw-r--r--dev-perl/Perlbal/ChangeLog7
-rw-r--r--dev-perl/Perlbal/Perlbal-1.780.ebuild44
-rw-r--r--dev-perl/URI/ChangeLog7
-rw-r--r--dev-perl/URI/URI-1.580.ebuild22
6 files changed, 119 insertions, 3 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.350.ebuild b/dev-perl/Apache-Test/Apache-Test-1.350.ebuild
new file mode 100644
index 000000000000..c86ec4ea9b24
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.350.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.350.ebuild,v 1.1 2011/01/23 15:32:24 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.35
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/ChangeLog b/dev-perl/Apache-Test/ChangeLog
index 8a05078b7112..e84e14d6f928 100644
--- a/dev-perl/Apache-Test/ChangeLog
+++ b/dev-perl/Apache-Test/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Apache-Test
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/ChangeLog,v 1.69 2011/01/18 16:48:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/ChangeLog,v 1.70 2011/01/23 15:32:24 tove Exp $
+
+*Apache-Test-1.350 (23 Jan 2011)
+
+ 23 Jan 2011; Torsten Veller <tove@gentoo.org> +Apache-Test-1.350.ebuild:
+ Version bump
*Apache-Test-1.340 (18 Jan 2011)
diff --git a/dev-perl/Perlbal/ChangeLog b/dev-perl/Perlbal/ChangeLog
index be020733d5b8..a35b461b986d 100644
--- a/dev-perl/Perlbal/ChangeLog
+++ b/dev-perl/Perlbal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Perlbal
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/ChangeLog,v 1.17 2011/01/17 12:43:53 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/ChangeLog,v 1.18 2011/01/23 15:29:51 tove Exp $
+
+*Perlbal-1.780 (23 Jan 2011)
+
+ 23 Jan 2011; Torsten Veller <tove@gentoo.org> +Perlbal-1.780.ebuild:
+ Version bump
*Perlbal-1.770 (17 Jan 2011)
diff --git a/dev-perl/Perlbal/Perlbal-1.780.ebuild b/dev-perl/Perlbal/Perlbal-1.780.ebuild
new file mode 100644
index 000000000000..8bd43bb93ca7
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.780.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/Perlbal-1.780.ebuild,v 1.1 2011/01/23 15:29:51 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=DORMANDO
+MODULE_VERSION=1.78
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/libwww-perl
+ >=dev-perl/Danga-Socket-1.57
+ dev-perl/Sys-Syscall
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO"
+DEPEND="${RDEPEND}"
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+
+PATCHES=( "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${FILESDIR}"/perlbal_init.d_1.58 perlbal
+ newconfd "${FILESDIR}"/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}
diff --git a/dev-perl/URI/ChangeLog b/dev-perl/URI/ChangeLog
index b57aa457cd69..ed3b4f3de357 100644
--- a/dev-perl/URI/ChangeLog
+++ b/dev-perl/URI/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/URI
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/URI/ChangeLog,v 1.84 2011/01/13 17:03:56 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/URI/ChangeLog,v 1.85 2011/01/23 15:28:07 tove Exp $
+
+*URI-1.580 (23 Jan 2011)
+
+ 23 Jan 2011; Torsten Veller <tove@gentoo.org> +URI-1.580.ebuild:
+ Version bump
13 Jan 2011; Brent Baude <ranger@gentoo.org> URI-1.55.ebuild:
Marking URI-1.55 ppc stable for bug 341865
diff --git a/dev-perl/URI/URI-1.580.ebuild b/dev-perl/URI/URI-1.580.ebuild
new file mode 100644
index 000000000000..4478c76cd71f
--- /dev/null
+++ b/dev-perl/URI/URI-1.580.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/URI/URI-1.580.ebuild,v 1.1 2011/01/23 15:28:07 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=1.58
+inherit perl-module
+
+DESCRIPTION="A URI Perl Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="virtual/perl-MIME-Base64"
+RDEPEND="${DEPEND}"
+
+SRC_TEST=no # see ChangeLog
+
+mydoc="rfc2396.txt"