summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-10-19 18:53:39 +0000
committerStuart Herbert <stuart@gentoo.org>2003-10-19 18:53:39 +0000
commit6cebe6059022e8abb2eac06fed1ee507ada4f3d5 (patch)
treed6a176ac7c82da6a1df20bca0fe531b48e27709a /dev-php/phpdbg/phpdbg-2.11.23.ebuild
parentVersion bump; closes bug #23870 (diff)
downloadhistorical-6cebe6059022e8abb2eac06fed1ee507ada4f3d5.tar.gz
historical-6cebe6059022e8abb2eac06fed1ee507ada4f3d5.tar.bz2
historical-6cebe6059022e8abb2eac06fed1ee507ada4f3d5.zip
Version bump; closes bug #23870
Diffstat (limited to 'dev-php/phpdbg/phpdbg-2.11.23.ebuild')
-rw-r--r--dev-php/phpdbg/phpdbg-2.11.23.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/phpdbg/phpdbg-2.11.23.ebuild b/dev-php/phpdbg/phpdbg-2.11.23.ebuild
new file mode 100644
index 000000000000..6a7e752e1cdc
--- /dev/null
+++ b/dev-php/phpdbg/phpdbg-2.11.23.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpdbg/phpdbg-2.11.23.ebuild,v 1.1 2003/10/19 18:53:29 stuart Exp $
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_ZENDEXT="no"
+inherit php-ext-source
+
+S="${WORKDIR}/dbg-${PV}-src"
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+SRC_URI="http://dd.cron.ru/dbg/dnld/dbg-${PV}${PL}-src.tar.gz"
+HOMEPAGE="http://dd.cron.ru/dbg/"
+LICENSE="dbgphp"
+SLOT="0"
+DEPEND="virtual/php"
+
+# support for ppc or others?
+KEYWORDS="x86 sparc "
+
+src_compile() {
+ myconf="--enable-dbg=shared --with-dbg-profiler --with-php-config=/usr/bin/php-config"
+ php-ext-source_src_compile
+}
+
+src_install () {
+ php-ext-source_src_install
+
+ dodoc AUTHORS COPYING INSTALL
+}
+
+pkg_postinst() {
+ php-ext-base_addtoinifiles "extension" "/etc/php4/lib/dbg.so"
+ php-ext-base_addtoinifiles "[Debugger]"
+ php-ext-base_addtoinifiles "debugger.enabled" "on"
+ php-ext-base_addtoinifiles "debugger.profiler_enabled" "on"
+ einfo Please reload Apache to activate the changes
+
+}
+
+pkg_postrm() {
+ einfo You need to remove all lines referring to the debugger, and
+ extension=dbg.so.Please reload Apache to activate the changes
+
+}
+