summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-04-16 12:58:22 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-04-16 12:58:22 +0000
commit292c37800f3858cc322ec452bc639af6e2b0f7ab (patch)
tree38e811d439055093285117e0a2a148d2eb70cfed /dev-php/phpmd
parentRemoved USE="hal". Bug #362847 (diff)
downloadhistorical-292c37800f3858cc322ec452bc639af6e2b0f7ab.tar.gz
historical-292c37800f3858cc322ec452bc639af6e2b0f7ab.tar.bz2
historical-292c37800f3858cc322ec452bc639af6e2b0f7ab.zip
Added support for local channel.xml
Package-Manager: portage-2.1.9.45/cvs/Linux x86_64
Diffstat (limited to 'dev-php/phpmd')
-rw-r--r--dev-php/phpmd/files/channel.xml16
-rw-r--r--dev-php/phpmd/phpmd-1.1.0.ebuild4
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-php/phpmd/files/channel.xml b/dev-php/phpmd/files/channel.xml
new file mode 100644
index 000000000000..148ac19cf83a
--- /dev/null
+++ b/dev-php/phpmd/files/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.phpmd.org</name>
+ <summary>PHP Mess Detector PEAR channel</summary>
+ <suggestedalias>phpmd</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.phpmd.org//rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.phpmd.org//rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.phpmd.org//rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.phpmd.org//rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/dev-php/phpmd/phpmd-1.1.0.ebuild b/dev-php/phpmd/phpmd-1.1.0.ebuild
index 242980af6871..70ce152064d8 100644
--- a/dev-php/phpmd/phpmd-1.1.0.ebuild
+++ b/dev-php/phpmd/phpmd-1.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpmd/phpmd-1.1.0.ebuild,v 1.1 2011/03/25 13:47:47 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpmd/phpmd-1.1.0.ebuild,v 1.2 2011/04/16 12:36:09 olemarkus Exp $
EAPI="3"
-PHP_PEAR_CHANNEL="pear.phpmd.org"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
PHP_PEAR_PN="PHP_PMD"
inherit php-pear-lib-r1