summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-05-02 10:09:27 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-05-02 10:09:27 +0000
commit88d416741d4e4a93c57d2c90886419f6d386f19a (patch)
tree312bc5703afbe93952f971f3ab6bc80151b17e79 /dev-php/xcache/xcache-2.0.0.ebuild
parentBump xdebug rc (diff)
downloadhistorical-88d416741d4e4a93c57d2c90886419f6d386f19a.tar.gz
historical-88d416741d4e4a93c57d2c90886419f6d386f19a.tar.bz2
historical-88d416741d4e4a93c57d2c90886419f6d386f19a.zip
Version bump. Bug 413101
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'dev-php/xcache/xcache-2.0.0.ebuild')
-rw-r--r--dev-php/xcache/xcache-2.0.0.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-php/xcache/xcache-2.0.0.ebuild b/dev-php/xcache/xcache-2.0.0.ebuild
new file mode 100644
index 000000000000..b92afe40d004
--- /dev/null
+++ b/dev-php/xcache/xcache-2.0.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-2.0.0.ebuild,v 1.1 2012/05/02 10:09:26 olemarkus Exp $
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHPSAPILIST="apache2 cgi fpm"
+
+USE_PHP="php5-3 php5-4"
+EAPI="4"
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="virtual/httpd-php
+!dev-php/eaccelerator !dev-php/pecl-apc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
+ php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
+ php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
+
+ php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
+ php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
+ php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
+ php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
+ php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
+ php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
+ php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
+ php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
+ php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
+ php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
+
+ php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
+ php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
+
+ php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}/admin"
+ doins admin/*
+ insinto "${PHP_EXT_SHARED_DIR}/coverager"
+ doins coverager/*
+}
+
+pkg_postinst() {
+ elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
+ elog "release were installed into ${ROOT}usr/share/php5/xcache/."
+}