summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-24 14:54:13 +0000
commita15945cdab2719cb95424b79d14c485f1c5fb149 (patch)
treee10d80bad50b8ad80426222dcd0a318771108c71 /dev-php5/jpgraph
parentGet rid of sql dep and assistant build, it's in another package now (diff)
downloadhistorical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.gz
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.tar.bz2
historical-a15945cdab2719cb95424b79d14c485f1c5fb149.zip
Version bump from the php-overlay
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-php5/jpgraph')
-rw-r--r--dev-php5/jpgraph/ChangeLog10
-rw-r--r--dev-php5/jpgraph/files/digest-jpgraph-2.33
-rw-r--r--dev-php5/jpgraph/jpgraph-2.3.ebuild90
3 files changed, 102 insertions, 1 deletions
diff --git a/dev-php5/jpgraph/ChangeLog b/dev-php5/jpgraph/ChangeLog
index edd95ebc9b72..7d8b647675a1 100644
--- a/dev-php5/jpgraph/ChangeLog
+++ b/dev-php5/jpgraph/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/jpgraph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.26 2007/11/14 15:27:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/ChangeLog,v 1.27 2007/12/24 14:45:33 armin76 Exp $
+
+*jpgraph-2.3 (24 Dec 2007)
+
+ 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> +jpgraph-2.3.ebuild:
+ Version bump from the php-overlay
+
+ 21 Dec 2007; Jakub Moc <jakub@gentoo.org> +jpgraph-2.3.ebuild:
+ Version bump
14 Nov 2007; Jeroen Roovers <jer@gentoo.org> jpgraph-2.2.ebuild:
Stable for HPPA (bug #198564).
diff --git a/dev-php5/jpgraph/files/digest-jpgraph-2.3 b/dev-php5/jpgraph/files/digest-jpgraph-2.3
new file mode 100644
index 000000000000..8e29dced6388
--- /dev/null
+++ b/dev-php5/jpgraph/files/digest-jpgraph-2.3
@@ -0,0 +1,3 @@
+MD5 a56d345810733aee2829cf56924a3f1a jpgraph-2.3.tar.gz 4619908
+RMD160 dcebe1591bc9ccd1a24d454b8890416d06e4ef4b jpgraph-2.3.tar.gz 4619908
+SHA256 f149ed7a45e4e2e8045f9ccf3f8342153d25766ffc0f0f7242cfcf7185b88fb9 jpgraph-2.3.tar.gz 4619908
diff --git a/dev-php5/jpgraph/jpgraph-2.3.ebuild b/dev-php5/jpgraph/jpgraph-2.3.ebuild
new file mode 100644
index 000000000000..f58c414c0a97
--- /dev/null
+++ b/dev-php5/jpgraph/jpgraph-2.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/jpgraph/jpgraph-2.3.ebuild,v 1.1 2007/12/24 14:45:33 armin76 Exp $
+
+inherit php-lib-r1 eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DESCRIPTION="Fully OO graph drawing library for PHP."
+HOMEPAGE="http://www.aditus.nu/jpgraph/"
+SRC_URI="http://hem.bredband.net/jpgraph2/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+IUSE="truetype"
+
+DEPEND=""
+RDEPEND="truetype? ( media-fonts/corefonts )"
+
+need_php_by_category
+
+[[ -z "${JPGRAPH_CACHEDIR}" ]] && JPGRAPH_CACHEDIR="/var/cache/jpgraph-php5/"
+
+pkg_setup() {
+ has_php
+
+ # we need the PHP GD functionality
+ require_gd
+
+ # check to wich user:group the cache dir will go
+ if has_version "www-servers/apache" ; then
+ HTTPD_USER="apache"
+ HTTPD_GROUP="apache"
+ einfo "Configuring ${JPGRAPH_CACHEDIR} for Apache."
+ else
+ HTTPD_USER="${HTTPD_USER:-root}"
+ HTTPD_GROUP="${HTTPD_GROUP:-root}"
+ ewarn "No Apache webserver detected - ${JPGRAPH_CACHEDIR} will be"
+ ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
+ ewarn "It this is not what you want, you can define"
+ ewarn "HTTPD_USER and HTTPD_GROUP variables and re-emerge ${PN}."
+ epause 3
+ fi
+}
+
+src_install() {
+ # some patches to adapt the config to Gentoo
+ einfo "Patching jpg-config.inc.php"
+
+ # patch 1:
+ # make jpgraph use the correct group for file permissions
+
+ sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 1"
+
+ # patch 2:
+ # make jpgraph use the correct directory for caching
+
+ sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHEDIR}\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 2"
+
+ # patch 3:
+ # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
+
+ if use truetype ; then
+ sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"/usr/share/fonts/corefonts/\");|" src/jpg-config.inc.php \
+ || die "sed failed in patch 3"
+ fi
+
+ # patch 4:
+ # disable READ_CACHE in jpgraph
+
+ sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc.php \
+ || die "sed failed in patch 4"
+
+ # install php files
+ einfo "Building list of files to install"
+ php-lib-r1_src_install src `cd src ; find . -type f -print`
+
+ # install documentation
+ einfo "Installing documentation"
+ dodoc-php README
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r docs/*
+
+ # setup the cache dir
+ einfo "Setting up the cache dir"
+ keepdir "${JPGRAPH_CACHEDIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHEDIR}"
+ fperms 750 "${JPGRAPH_CACHEDIR}"
+}