summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-09-29 17:06:40 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-09-29 17:06:40 +0000
commitaa910ead543e3d3ec2ee8e674cfe1b5ee1d59f20 (patch)
treed889d88bdbf0cfd1921c94f89cd9d0b41e2abff6 /dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild
parentAdded patch for MMX and closing bug #145245. (diff)
downloadhistorical-aa910ead543e3d3ec2ee8e674cfe1b5ee1d59f20.tar.gz
historical-aa910ead543e3d3ec2ee8e674cfe1b5ee1d59f20.tar.bz2
historical-aa910ead543e3d3ec2ee8e674cfe1b5ee1d59f20.zip
Version bump.
Package-Manager: portage-2.1.2_pre1-r4
Diffstat (limited to 'dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild')
-rw-r--r--dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild b/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild
new file mode 100644
index 000000000000..f3fcb0f6100a
--- /dev/null
+++ b/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.1.ebuild,v 1.1 2006/09/29 17:06:40 sebastian Exp $
+
+PHP_EXT_NAME="pdo_sqlite"
+PHP_EXT_PECL_PKG="PDO_SQLITE"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+DESCRIPTION="PHP Data Objects (PDO) Driver For SQLite Server."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-php5/pecl-pdo"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # if the user has compiled in PDO, he can't use this package
+ if built_with_use =${PHP_PKG} pdo ; then
+ eerror
+ eerror "You have built ${PHP_PKG} to use the bundled PDO support."
+ eerror "If you want to use the PECL PDO packages, you must rebuild"
+ eerror "your PHP with the 'pdo-external' USE flag instead."
+ eerror
+ die "PHP built to use bundled PDO support"
+ fi
+}