summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-09-08 08:26:30 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-09-08 08:26:30 +0000
commit11717d269ddcc2b766899df9c1658d2bad3e2e13 (patch)
treea5fb4e39610053bf8e3b3322fab1efc99fd08ab7 /dev-php5/phpunit
parentMove dev-php5/PEAR-PHPUnit2 to dev-php5/phpunit (1/2). (diff)
downloadhistorical-11717d269ddcc2b766899df9c1658d2bad3e2e13.tar.gz
historical-11717d269ddcc2b766899df9c1658d2bad3e2e13.tar.bz2
historical-11717d269ddcc2b766899df9c1658d2bad3e2e13.zip
Move dev-php5/PEAR-PHPUnit2 to dev-php5/phpunit (2/2).
Package-Manager: portage-2.1.1_rc1-r7
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog10
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-2.3.63
-rw-r--r--dev-php5/phpunit/metadata.xml5
-rw-r--r--dev-php5/phpunit/phpunit-2.3.6.ebuild27
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
new file mode 100644
index 000000000000..91675d49b24c
--- /dev/null
+++ b/dev-php5/phpunit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php5/phpunit
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.1 2006/09/08 08:26:30 sebastian Exp $
+
+*phpunit-2.3.6 (08 Sep 2006)
+
+ 08 Sep 2006; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+ +phpunit-2.3.6.ebuild:
+ Initial ebuild.
+
diff --git a/dev-php5/phpunit/files/digest-phpunit-2.3.6 b/dev-php5/phpunit/files/digest-phpunit-2.3.6
new file mode 100644
index 000000000000..e93b08791283
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-2.3.6
@@ -0,0 +1,3 @@
+MD5 53161dc2fffe395074e6699919cdc8c2 PHPUnit-2.3.6.tgz 41548
+RMD160 1c1beb139cb49e17052b725c9589eae3b1572c4b PHPUnit-2.3.6.tgz 41548
+SHA256 2bb09189cf88d75f8487d4caf583eec7e38e31dea5a5741b44932b1e301a7b41 PHPUnit-2.3.6.tgz 41548
diff --git a/dev-php5/phpunit/metadata.xml b/dev-php5/phpunit/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php5/phpunit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php5/phpunit/phpunit-2.3.6.ebuild b/dev-php5/phpunit/phpunit-2.3.6.ebuild
new file mode 100644
index 000000000000..f52e4ae5a0b4
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-2.3.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-2.3.6.ebuild,v 1.1 2006/09/08 08:26:30 sebastian Exp $
+
+inherit php-pear-lib-r1
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+DEPEND="!dev-php4/phpunit"
+RDEPEND=">=dev-php/PEAR-Benchmark-1.2.2-r1
+ >=dev-php/PEAR-Log-1.8.7-r1"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+S="${WORKDIR}/PHPUnit-${PV}"
+
+pkg_setup() {
+ require_php_with_use pcre spl xml
+
+ if has_version '>=dev-lang/php-5.1.2' ; then
+ require_php_with_use reflection
+ fi
+}
+
+need_php_by_category