summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-26 20:50:07 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-26 20:50:07 +0000
commit2a74a2faaaa609f270bb0db953e4ae5997ff3a28 (patch)
tree79f46394ca1a7a9e15099349fbe7cfd8ad0d1e13 /dev-php
parentupdate DEPEND (diff)
downloadhistorical-2a74a2faaaa609f270bb0db953e4ae5997ff3a28.tar.gz
historical-2a74a2faaaa609f270bb0db953e4ae5997ff3a28.tar.bz2
historical-2a74a2faaaa609f270bb0db953e4ae5997ff3a28.zip
Fixes to PHP for gcc 3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog6
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild13
2 files changed, 11 insertions, 8 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 91846030f730..24c3a017baa3 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.7 2002/08/19 00:02:21 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.8 2002/08/26 20:50:07 rphillips Exp $
*php-4.2.2-r1 (18 Aug 2002)
+ 26 Aug 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.2-r1.ebuild :
+
+ Fixes for gcc 3.2
+
18 Aug 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.2-r1.ebuild :
Should fix pdflib/jpeg/tiff/java bug... #2708
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index 367185564798..8a1a5d9dba9b 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.2 2002/08/26 20:16:51 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.3 2002/08/26 20:50:07 rphillips Exp $
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -32,8 +32,7 @@ DEPEND=">=dev-libs/gmp-3.1.1
ldap? ( >=net-nds/openldap-1.2.11 )
odbc? ( >=dev-db/unixODBC-1.8.13 )
xml2? ( dev-libs/libxml2 )
- crypt? ( >=dev-libs/libmcrypt-2.4
- >=app-crypt/mhash-0.8 )
+ crypt? ( >=dev-libs/libmcrypt-2.4 >=app-crypt/mhash-0.8 )
mysql? ( >=dev-db/mysql-3.23.26 )
flash? ( media-libs/libswf >=media-libs/ming-0.2a )
berkdb? ( >=sys-libs/db-3 )
@@ -83,7 +82,7 @@ src_compile() {
local myconf
- use readline && myconf="${myconf} --with-readline"
+ use readline && myconf="${myconf} --enable-readline"
use pam && myconf="${myconf} --with-pam"
use nls && myconf="${myconf} --with-gettext" || myconf="${myconf} --without-gettext"
use ssl && myconf="${myconf} --with-openssl"
@@ -92,7 +91,7 @@ src_compile() {
use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
use gdbm && myconf="${myconf} --with-gdbm=/usr"
use berkdb && myconf="${myconf} --with-db3=/usr"
- use mysql && myconf="${myconf} --with-mysql=/usr" || myconf="${myconf} --without-mysql"
+ use mysql && myconf="${myconf} --enable-mysql=/usr" || myconf="${myconf} --without-mysql"
use postgres && myconf="${myconf} --with-pgsql=/usr"
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
@@ -103,7 +102,7 @@ src_compile() {
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
- myconf="${myconf} --with-pdflib=/usr"
+ myconf="${myconf} --enable-pdflib=/usr"
else
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
@@ -142,7 +141,7 @@ src_compile() {
fi
use xml2 && myconf="${myconf} --with-dom"
- use crypt && myconf="${myconf} --with-mcrypt --with-mhash"
+ use crypt && myconf="${myconf} --enable-mcrypt=/usr --with-mhash"
use java && myconf="${myconf} --with-java=${JDK_HOME}"
LDFLAGS="$LDFLAGS -ltiff -ljpeg"