summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-11-05 22:26:25 +0000
committerStuart Herbert <stuart@gentoo.org>2003-11-05 22:26:25 +0000
commita9873d24f2b12c3548e6f7eaf8c84c6ba0562f79 (patch)
tree0bad31491df0d78adfd2a31b1d0bcee8aad9ef66 /dev-php
parentVersion bump (diff)
downloadhistorical-a9873d24f2b12c3548e6f7eaf8c84c6ba0562f79.tar.gz
historical-a9873d24f2b12c3548e6f7eaf8c84c6ba0562f79.tar.bz2
historical-a9873d24f2b12c3548e6f7eaf8c84c6ba0562f79.zip
Version bump
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/turck-mmcache/Manifest4
-rw-r--r--dev-php/turck-mmcache/files/digest-turck-mmcache-2.4.61
-rw-r--r--dev-php/turck-mmcache/turck-mmcache-2.4.6.ebuild77
3 files changed, 80 insertions, 2 deletions
diff --git a/dev-php/turck-mmcache/Manifest b/dev-php/turck-mmcache/Manifest
index 6e0937e2fc80..e4b93166dedc 100644
--- a/dev-php/turck-mmcache/Manifest
+++ b/dev-php/turck-mmcache/Manifest
@@ -1,12 +1,12 @@
MD5 8fe8d697581a87240d5729b112ddfa36 turck-mmcache-2.4.2.ebuild 2591
MD5 f70fb61786a2c8d148e6a9c7b54d5b3f turck-mmcache-2.3.22.ebuild 2404
MD5 4f11d817f510e117ecea35cf06410ebc turck-mmcache-2.4.4.ebuild 2590
-MD5 636fd7bb728b7ddf719731abf2a58fa6 turck-mmcache-2.4.6.ebuild 2590
+MD5 d48a6b7a0fb145bc7d44a77255e0112f turck-mmcache-2.4.6.ebuild 2590
MD5 168accb4420df208a25c892a1667fa7b turck-mmcache-2.4.1.ebuild 2590
MD5 2ff33d4b37007a31d9061cf43989fcce turck-mmcache-2.3.21.ebuild 2350
MD5 0459beac3ce0b38cbe3e29c825c00c05 turck-mmcache-2.4.3.ebuild 2590
MD5 785041ac484021b7af77e3beb42a4b33 turck-mmcache-2.3.23.ebuild 2404
-MD5 afc38b60341dd8034704425ec57d7084 ChangeLog 3264
+MD5 c6aac76510b2546a2ee3dae395f669dc ChangeLog 3394
MD5 73c76c179e62f232ca675b8a15fe62ec metadata.xml 218
MD5 636fd7bb728b7ddf719731abf2a58fa6 turck-mmcache-2.4.5.ebuild 2590
MD5 6a2984bdec88313a20f529e849519cb0 turck-mmcache-2.3.20.ebuild 2348
diff --git a/dev-php/turck-mmcache/files/digest-turck-mmcache-2.4.6 b/dev-php/turck-mmcache/files/digest-turck-mmcache-2.4.6
new file mode 100644
index 000000000000..6868b8c0ec91
--- /dev/null
+++ b/dev-php/turck-mmcache/files/digest-turck-mmcache-2.4.6
@@ -0,0 +1 @@
+MD5 bcf671bec2e8b009e9b2d8f8d2574041 turck-mmcache-2.4.6.tar.gz 117130
diff --git a/dev-php/turck-mmcache/turck-mmcache-2.4.6.ebuild b/dev-php/turck-mmcache/turck-mmcache-2.4.6.ebuild
new file mode 100644
index 000000000000..106de544e85a
--- /dev/null
+++ b/dev-php/turck-mmcache/turck-mmcache-2.4.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/turck-mmcache/turck-mmcache-2.4.6.ebuild,v 1.1 2003/11/05 22:26:21 stuart Exp $
+
+PHP_EXT_NAME="mmcache"
+PHP_EXT_ZENDEXT="yes"
+[ -z "${MMCACHE_CACHEDIR}" ] && MMCACHE_CACHEDIR=/var/cache/mmcache
+inherit php-ext-source
+
+DESCRIPTION="open source PHP accelerator, optimizer, encoder and dynamic content cache"
+HOMEPAGE="http://turck-mmcache.sourceforge.net/"
+SRC_URI="mirror://sourceforge/turck-mmcache/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="$DEPEND
+ !dev-php/ioncube_loaders
+ !dev-php/php-accelerator
+ !dev-php/PECL-apc"
+
+src_compile() {
+ myconf="--enable-mmcache=shared"
+ php-ext-source_src_compile
+}
+
+src_install() {
+ php-ext-source_src_install
+
+ # create Cache dir if it does not exist
+ #
+ # settings should ensure that cached files are secure,
+ # *but* this may break php-cli
+ #
+ # please file a bug in http://bugs.gentoo.org if this happens
+ # for you
+
+ keepdir ${MMCACHE_CACHEDIR}
+ fowners root.root ${MMCACHE_CACHEDIR}
+ fperms 1777 ${MMCACHE_CACHEDIR}
+
+ insinto /usr/share/${PN}
+ doins encoder.php mmcache.php mmcache.gif
+
+ dodoc CREDITS LICENSE README TODO EXPERIMENTAL
+
+ php-ext-base_addtoinifiles "mmcache.shm_size" '"16"'
+ php-ext-base_addtoinifiles "mmcache.cache_dir" "\"${MMCACHE_CACHEDIR}\""
+ php-ext-base_addtoinifiles "mmcache.enable" '"1"'
+ php-ext-base_addtoinifiles "mmcache.optimizer" '"1"'
+ php-ext-base_addtoinifiles "mmcache.check_mtime" '"1"'
+ php-ext-base_addtoinifiles "mmcache.debug" '"0"'
+ php-ext-base_addtoinifiles "mmcache.filter" '""'
+ php-ext-base_addtoinifiles "mmcache.shm_max" '"0"'
+ php-ext-base_addtoinifiles "mmcache.shm_ttl" '"0"'
+ php-ext-base_addtoinifiles "mmcache.shm_prune_period" '"0"'
+ php-ext-base_addtoinifiles "mmcache.compress" '"0"'
+ php-ext-base_addtoinifiles "mmcache.shm_only" '"0"'
+ php-ext-base_addtoinifiles "mmcache.keys" '"shm_and_disk"'
+ php-ext-base_addtoinifiles "mmcache.sessions" '"shm_and_disk"'
+ php-ext-base_addtoinifiles "mmcache.content" '"shm_and_disk"'
+
+}
+
+pkg_postinst () {
+
+ einfo "You need to restart apache to activate MMCache"
+ einfo
+ einfo 'A web interface is available to manage the turck cache.'
+ einfo 'Copy /usr/share/turck-mmcache/mmcache.php to somewhere'
+ einfo 'where your web server can see it.'
+ einfo
+ einfo 'A PHP script encoder is available to encode your PHP scripts.'
+ einfo 'The encoder is available as /usr/share/turck-mmcache/encoder.php'
+ einfo 'The encoded file format is not yet considered stable'
+}