summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-07 23:18:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-07 23:18:29 +0000
commitdf906d5752b1e3d5f8dbb94267010f7daed35978 (patch)
tree73a25a475016ea67bba1151ab56b9a46b287c8a7 /dev-php
parentbug #32962, new version (diff)
downloadhistorical-df906d5752b1e3d5f8dbb94267010f7daed35978.tar.gz
historical-df906d5752b1e3d5f8dbb94267010f7daed35978.tar.bz2
historical-df906d5752b1e3d5f8dbb94267010f7daed35978.zip
bug #32962, new version
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest4
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.43
-rw-r--r--dev-php/mod_php/mod_php-4.3.4.ebuild175
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest26
5 files changed, 200 insertions, 15 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index 80bfc3bc7cb2..403b6221fc95 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -2,14 +2,14 @@ MD5 ad12767019b879b7c9fdd216bf02992c mod_php-4.3.2.ebuild 3396
MD5 9a9440cc176c36cf06f31d0a2cd96129 mod_php-4.3.3-r2.ebuild 5287
MD5 2ffcbd3deb771e2765ea62a15aa6160f mod_php-4.3.2-r5.ebuild 5113
MD5 baaa4e7f9b1f85ece366d0a48203ffd4 mod_php-4.3.3_rc3.ebuild 5132
-MD5 5bfd28d68e2b59143eda617bac0335af mod_php-4.3.4.ebuild 5290
+MD5 3224efbbbd51297bd8a9999a79c7a1df mod_php-4.3.4.ebuild 5289
MD5 70c4a70166685022a7ef99e972141843 mod_php-4.3.2-r2.ebuild 3699
MD5 304e7c5b3bd5f88890ae9da627c78499 mod_php-4.3.3-r1.ebuild 4942
MD5 36eecb3ee3e24ff2838a2d43cc09dc54 mod_php-4.3.2-r4.ebuild 4982
MD5 97acd0f21caff5ff8dde4e11fc76a00b mod_php-4.3.3.ebuild 4902
MD5 5bfd28d68e2b59143eda617bac0335af mod_php-4.3.3-r3.ebuild 5290
MD5 5580ac72681bb57c10b3e8f86e88c0d1 mod_php-4.3.2-r1.ebuild 2763
-MD5 8e222937f22d6ed4ed8694f4ae4df250 ChangeLog 22223
+MD5 d0c116b059f958e20badc21779b4641e ChangeLog 22355
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 4cb22f3a36dbc2cc5a6d5a2f3e02b567 mod_php-4.3.2-r3.ebuild 4942
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.4 b/dev-php/mod_php/files/digest-mod_php-4.3.4
new file mode 100644
index 000000000000..2f7602289366
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.4
@@ -0,0 +1,3 @@
+MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
+MD5 a5dd907ca0aed4ba38c79181d407cbff php-4.3.4-phpizeexecfix.patch 386
diff --git a/dev-php/mod_php/mod_php-4.3.4.ebuild b/dev-php/mod_php/mod_php-4.3.4.ebuild
new file mode 100644
index 000000000000..a90e10f2c903
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.4.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.4.ebuild,v 1.1 2003/11/07 23:16:29 robbat2 Exp $
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm ~amd64"
+
+detectapache() {
+ local domsg=
+ [ -n "$1" ] && domsg=1
+ HAVE_APACHE1=
+ HAVE_APACHE2=
+ has_version '=net-www/apache-1*' && HAVE_APACHE1=1
+ has_version '=net-www/apache-2*' && HAVE_APACHE2=1
+
+ [ -n "${HAVE_APACHE1}" ] && APACHEVER=1
+ [ -n "${HAVE_APACHE2}" ] && APACHEVER=2
+ [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" ] && APACHEVER='both'
+
+ case "${APACHEVER}" in
+ 1) [ -n "${domsg}" ] && einfo 'Apache1 only detected' ;;
+ 2) [ -n "${domsg}" ] && einfo 'Apache2 only detected';;
+ both)
+ if [ "`use apache2`" ]; then
+ [ -n "${domsg}" ] && einfo "Multiple Apache versions detected, using Apache2 (USE=apache2)"
+ APACHEVER=2
+ else
+ [ -n "${domsg}" ] && einfo 'Multiple Apache versions detected, using Apache1 (USE=-apache2)'
+ APACHEVER=1
+ fi ;;
+ *) if [ -n "${domsg}" ]; then
+ MSG="Unknown Apache version!"; eerror $MSG ; die $MSG
+ else
+ APACHEVER=0
+ fi; ;;
+ esac
+}
+
+detectapache
+
+SLOT="${APACHEVER}"
+[ "${APACHEVER}" -eq '2' ] && USE_APACHE2='2' || USE_APACHE2=''
+
+PHPSAPI="apache${APACHEVER}"
+
+# BIG FAT WARNING!
+# the php eclass requires the PHPSAPI setting!
+# In this case the PHPSAPI setting is dependant on the detectapache function
+# above this point as well!
+inherit php eutils
+
+DEPEND="${DEPEND}
+ >=net-www/apache-1.3.26-r2
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ >=sys-apps/findutils-4.1.7-r5
+ "
+
+pkg_setup() {
+ if has_version '=sys-apps/findutils-4.1.20'; then
+ eerror "Sorry, you need to have >=sys-apps/findutils-4.1.20-r1"
+ eerror "installed, due to a shortcoming in Portage we can't"
+ eerror "put it into the DEPEND list yet (to be fixed soon)..."
+ die
+ fi
+}
+
+src_unpack() {
+ multiinstwarn
+ detectapache domsg
+ php_src_unpack
+}
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ -n "${USE_APACHE2}" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|perchild|leader|threadpool|prefork'|cut -d. -f1|sed -e 's/^[[:space:]]*//g;s/[[:space:]]+/ /g;'`"
+ einfo "Apache2 MPM: ${APACHE2_MPM}"
+ case "${APACHE2_MPM}" in
+ *prefork*) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ; ewarn "Enabling ZTS for Apache2 MPM" ;;
+ esac;
+ fi
+
+ #use apache2 \
+ myconf="${myconf} --with-apxs${USE_APACHE2}=/usr/sbin/apxs${USE_APACHE2}"
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+ einfo "Adding extra symlink to php.ini for Apache${USE_APACHE2}"
+ dodir /etc/apache${USE_APACHE2}/conf/
+ dodir ${PHPINIDIRECTORY}
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache${USE_APACHE2}/conf/${PHPINIFILENAME}
+
+ einfo "Adding extra symlink to Apache${USE_APACHE2} extramodules for PHP"
+ dosym /usr/lib/apache${USE_APACHE2}-extramodules ${PHPINIDIRECTORY}/lib
+ exeinto /usr/lib/apache${USE_APACHE2}-extramodules
+ einfo "Installing mod_php shared object now"
+ doexe .libs/libphp4.so
+
+ if [ -n "${USE_APACHE2}" ] ; then
+ einfo "Installing a Apache2 config for PHP (70_mod_php.conf)"
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ else
+ einfo "Installing a Apache config for PHP (mod_php.conf)"
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym ${PHPINIDIRECTORY}/${PHPINIFILENAME} /etc/apache/conf/addon-modules/${PHPINIFILENAME}
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\" to APACHE2_OPTS"
+ ewarn "This is a CHANGE from previous behavior, which was \"-D PHP\""
+ ewarn "This is for the upcoming PHP5 support. The ebuild will attempt"
+ ewarn "to make this update between PHP and PHP4 automatically"
+}
+
+multiinstwarn() {
+ ewarn "Due to some previous bloopers with PHP and slotting, you may have"
+ ewarn "multiple copies of mod_php installed. Please look at the autoclean"
+ ewarn "output at the end of the emerge and unmerge all but relevant"
+ ewarn "copies."
+}
+
+apache2fix() {
+ einfo "Attemping to update /etc/conf.d/apache2 automatically for the PHP/PHP4 change."
+ local oldfile="/etc/conf.d/apache2.old.`date +%Y%m%d%H%M%S`"
+ cp /etc/conf.d/apache2 ${oldfile}
+ sed -re 's,-D PHP\>,-D PHP4,g' ${oldfile} <${oldfile} >/etc/conf.d/apache2
+}
+
+
+pkg_preinst() {
+ multiinstwarn
+ [ "${APACHEVER}" -eq '2' ] && apache2fix
+ php_pkg_preinst
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ multiinstwarn
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP4\" to APACHE_OPTS"
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ multiinstwarn
+ if [ -n "${USE_APACHE2}" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 9815ba6a3529..4effa282fd53 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.63 2003/10/26 04:16:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.64 2003/11/07 23:18:29 robbat2 Exp $
+
+*php-4.3.4 (07 Nov 2003)
+
+ 07 Nov 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.4.ebuild:
+ bug #32962, new version
25 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> php-5.0_beta1-r1.ebuild:
fix bug #25326 hopefully
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index f234df5ffcb6..bbd9e249a2bb 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,4 +1,16 @@
-MD5 3d6fd0dabba5f9c3beb6357b0cf36adc php-5.0_beta1-r1.ebuild 1296
+MD5 49677578b21e86c1db7a1561d04f754a php-5.0_beta1-r1.ebuild 1295
+MD5 0d9585a857a06f4d336cf647dd8728d4 php-4.3.2-r3.ebuild 1140
+MD5 c8cc2dc8ab39618308726f1749d14d61 php-4.3.3-r2.ebuild 1207
+MD5 25f97fc9df6d134f3da1b4e5c1414830 php-4.3.2.ebuild 2418
+MD5 3eeafc4e390ffd783e014a5ec877e820 php-4.3.2-r2.ebuild 1182
+MD5 bc498859e45cdd2924f64ae5ef806239 php-4.3.4.ebuild 1210
+MD5 f1385520cac897796eeae1ad974ac15c php-4.3.3-r1.ebuild 1208
+MD5 ff00712ef064fedea5c310204c367b1a php-5.0_beta1.ebuild 1176
+MD5 9751be17197a00183a15d02ff78ebe8a ChangeLog 9667
+MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
+MD5 db16022e0ec00d919b30ab222f073577 php-4.3.3-r3.ebuild 1218
+MD5 ce0950f7facac1bcd6c3f99321f4648a php-4.3.2-r1.ebuild 990
+MD5 bc498859e45cdd2924f64ae5ef806239 php-4.3.3.ebuild 1210
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r2 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r3 137
@@ -9,15 +21,5 @@ MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1-r1 65
MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2 137
MD5 e007fc4a17373504abd024180c0d0b3f files/digest-php-4.3.3 137
+MD5 85d30f5e2707a53bd35b201a29371f05 files/digest-php-4.3.4 208
MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1 65
-MD5 9960c1a7ed72f9fdedce49456bd805a2 php-4.3.2-r3.ebuild 1141
-MD5 66ce848fd56119473b2d66722f59316b php-4.3.3-r2.ebuild 1208
-MD5 f09650e6c25eea6768304c608e96fac6 php-4.3.2.ebuild 2419
-MD5 fb73db8354092f57ac65bf17eb9b5ba9 php-4.3.2-r2.ebuild 1183
-MD5 5d0eff803459486b748cd3b47da21c39 php-4.3.3-r1.ebuild 1209
-MD5 02965cb9de4d44841d680156e18c96b2 php-5.0_beta1.ebuild 1177
-MD5 14045f57094153cd226c47331fa5a55a ChangeLog 9668
-MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
-MD5 4853c60510825040397e1510f17f3077 php-4.3.3-r3.ebuild 1219
-MD5 fb86d5617b1f16c5db4b2d8408f149ba php-4.3.2-r1.ebuild 991
-MD5 641b63b1b80eb8d2cf90d557ee48edaa php-4.3.3.ebuild 1211