summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-05-26 19:55:06 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-05-26 19:55:06 +0000
commit9d18558f1ee3d3321a1d1d6a4d4bd3ad69f725eb (patch)
tree039a36741e1360c6ae758425a3894ea6d2a0907d /dev-python/PyQt/PyQt-3.12.ebuild
parentupdated depend (diff)
downloadhistorical-9d18558f1ee3d3321a1d1d6a4d4bd3ad69f725eb.tar.gz
historical-9d18558f1ee3d3321a1d1d6a4d4bd3ad69f725eb.tar.bz2
historical-9d18558f1ee3d3321a1d1d6a4d4bd3ad69f725eb.zip
mirror://gentoo fixes, version bump
Diffstat (limited to 'dev-python/PyQt/PyQt-3.12.ebuild')
-rw-r--r--dev-python/PyQt/PyQt-3.12.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/PyQt/PyQt-3.12.ebuild b/dev-python/PyQt/PyQt-3.12.ebuild
new file mode 100644
index 000000000000..3d35b20f792a
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.12.ebuild,v 1.1 2004/05/26 19:55:06 carlo Exp $
+
+inherit distutils
+
+IUSE="doc"
+
+MY_P="PyQt-x11-gpl-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-3.10.2
+ <=dev-python/qscintilla-1.60"
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+ sed -i -e "s/ check_license()/# check_license()/" configure.py
+ python configure.py \
+ -d /usr/lib/python${PYVER}/site-packages \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -c
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && ( dohtml doc/PyQt.html
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples )
+}