summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:30:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 14:30:54 +0000
commit9a6ea3671173469e5a0166451f55c095a28502b4 (patch)
treea19e4896df0f1b8a87478cde1e01a18ae5a379b0 /dev-python/elixir
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-9a6ea3671173469e5a0166451f55c095a28502b4.tar.gz
historical-9a6ea3671173469e5a0166451f55c095a28502b4.tar.bz2
historical-9a6ea3671173469e5a0166451f55c095a28502b4.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/elixir')
-rw-r--r--dev-python/elixir/elixir-0.6.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/elixir/elixir-0.6.1.ebuild b/dev-python/elixir/elixir-0.6.1.ebuild
deleted file mode 100644
index 33ee0be91c85..000000000000
--- a/dev-python/elixir/elixir-0.6.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elixir/elixir-0.6.1.ebuild,v 1.1 2008/09/30 03:47:41 neurogeek Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils
-
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=Elixir
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A declarative layer on top of SQLAlchemy."
-HOMEPAGE="http://elixir.ematia.de/"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/sqlalchemy-0.4.0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( >=dev-python/docutils-0.4-r3
- >=dev-python/elementtree-1.2.6
- >=dev-python/kid-0.9
- >=dev-python/pygments-0.8.1
- >=dev-python/pudge-0.1.3
- >=dev-python/buildutils-0.3 )
- test? ( dev-python/nose )"
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- distutils_src_compile
- if use doc ; then
- einfo "Generating docs as requested..."
- ${python} setup.py addcommand -p buildutils.pudge_command
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r build/doc/*
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- PYTHONPATH=. "${python}" setup.py test || die "tests failed"
-}