summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-02 22:32:45 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-02 22:32:45 +0000
commitf463c3b2bbe3555cbf151e52bef648bc6f899253 (patch)
tree2c7b6a9d19942edcb79d594569bfbb609290a5f0 /dev-python/numeric/numeric-23.1.ebuild
parentmoving dev-python/Numeric to dev-python/numeric (diff)
downloadhistorical-f463c3b2bbe3555cbf151e52bef648bc6f899253.tar.gz
historical-f463c3b2bbe3555cbf151e52bef648bc6f899253.tar.bz2
historical-f463c3b2bbe3555cbf151e52bef648bc6f899253.zip
moving dev-python/Numeric to dev-python/numeric
Diffstat (limited to 'dev-python/numeric/numeric-23.1.ebuild')
-rw-r--r--dev-python/numeric/numeric-23.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/numeric/numeric-23.1.ebuild b/dev-python/numeric/numeric-23.1.ebuild
new file mode 100644
index 000000000000..3c7d63b0df9d
--- /dev/null
+++ b/dev-python/numeric/numeric-23.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-23.1.ebuild,v 1.1 2003/09/02 22:24:02 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/n/N}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical Python adds a fast, compact, multidimensional array language facility to Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+LICENSE="as-is"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_install() {
+
+ distutils_src_install
+ distutils_python_version
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+