summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-14 07:43:04 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-14 07:43:04 +0000
commitd2f9411d602c9f9fa964e6b9e8984b3cde002b3e (patch)
tree2cc444faa3ff650786742babbe731fe3804919fa /dev-python/psycopg/psycopg-2.4.2.ebuild
parentVersion bump. (diff)
downloadhistorical-d2f9411d602c9f9fa964e6b9e8984b3cde002b3e.tar.gz
historical-d2f9411d602c9f9fa964e6b9e8984b3cde002b3e.tar.bz2
historical-d2f9411d602c9f9fa964e6b9e8984b3cde002b3e.zip
Version bump psycopg to 2.4.2 (bug 379601).
Package-Manager: portage-2.1.10.15/cvs/Linux x86_64
Diffstat (limited to 'dev-python/psycopg/psycopg-2.4.2.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.4.2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/psycopg/psycopg-2.4.2.ebuild b/dev-python/psycopg/psycopg-2.4.2.ebuild
new file mode 100644
index 000000000000..6d838178d888
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.2.ebuild,v 1.1 2011/09/14 07:43:04 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+RDEPEND=">=dev-db/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="AUTHORS doc/HACKING doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+ epatch "${FILESDIR}/${P}-begin-segfault.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ python_convert_shebangs 2 doc/src/tools/stitch_text.py
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd doc > /dev/null
+ emake -j1 html text || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/psycopg2.txt || die "dodoc failed"
+
+ pushd doc/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}